[jadmin] Registration Questions

Thomas Muldowney temas at box5.net
Thu Mar 29 12:56:55 CST 2001


Reply spread throughout:


--temas

On Thu, Mar 29, 2001 at 11:05:01AM -0600, Kevin Hollenshead wrote:
> Temas,
> 
> Thanks for the reply.   I'll bounce my server (even though I hate to - it's been going strong for 2 weeks straight) and put it in debug mode and see what I can get out of it.
> 

Glad to hear it's running strong!

> Regarding the admin IDs, here are some questions that I had that were unclear from reading the comments in the default jabber.xml file.
> 
> * Does each user listed as having read and write receive all admin messages, including registration notifications?
> 
Yes, registration notices can be turned off by removing the notify='yes' flag
in the <register/> element.

> * If an alternate user has admin access (my normal ID, let's say) and I want to broadcast a message, can I set a "reply-to" on the message such that replies will go to a different ID (a special admin ID)?  Notifications (at least in JabberIM) appear as being
> from "@jabber.mydomainname.com" when I might want them to appear to be from "jabber at jabber.mydomainname.com".  Better yet, does this even matter?  Will a reply or message to "@jabber.mydomainname.com" be sent to every admin user?
> 

Yes, messages sent to the server are broadcasted to the admins with the subject
line modified to note that.


> * What is the format for multiple IDs?  Is is "<read>user1</read><read>user2</read>" or is it "<read>user1 user2</read>" or something else?
> 
<read>user1</read><read>user2</read>

> * Since the IDs have to be local for admin access, can I leave them in local format (i.e. "jabber") or should they be fully-qualified (i.e. "jabber at jabber.mydomain.com")?
> 

Full JIDs

> Thanks,
> 
> Kevin Hollenshead
> Sprint
> texasaggie at jabber.com
> 
> temas at box5.net wrote:
> 
> > Well, first, if you have <write/> you have implied <read/> so you only need
> > that.  Next.  Is the jabber use fully valid?  that's the only reason I could
> > think of that error occuring.  Can we see some of the debug around it?
> >
> > --temas
> >
> > On Wed, Mar 28, 2001 at 01:32:06PM -0600, Kevin Hollenshead wrote:
> > > Background: I am running Jabber 1.4 on Solaris 2.6.  I've got conferencing and JUD working just fine.  I can't test AIM because we have an HTTP proxy instead of a SOCKS one.
> > >
> > > I setup an admin ID (jabber) on that server and specified the following information in the jabber.xml file:
> > >
> > >       <register notify="yes">
> > >         <instructions>Choose a username and password to register with this server.</instructions>
> > >         <name/>
> > >         <email/>
> > >       </register>
> > > ......
> > >      <admin>
> > >         <read>jabber at jabber.dev.sprint.com</read>
> > >         <write>jabber at jabber.dev.sprint.com</write>
> > >         <reply>
> > >           <subject>Auto Reply</subject>
> > >           <body>This is a special administrative address.</body>
> > >         </reply>
> > >       </admin>
> > >
> > >
> > > When a new user registers, I get the notification for it twice but I get the following error in the server log:
> > >
> > > 20010328T12:21:59: [warn] (-internal): jsm: Invalid Recipient, returning data <message to='jabber.dev.sprint.com' from='jabber.dev.sprint.com'><body>The user sprint at jabber.dev.sprint.com was just created with the following registration data: &lt;query
> > > xmlns=&apos;jabber:iq:register&apos;&gt;&lt;resource&gt;Work&lt;/resource&gt;&lt;name&gt;MyFirstName MyLastName&lt;/name&gt;&lt;email&gt;myEmail&lt;/email&gt;&lt;x xmlns=&apos;jabber:x:delay&apos;
> > > stamp=&apos;20010328T12:21:59&apos;&gt;registered&lt;/x&gt;&lt;/query&gt;</body>
> > >
> > > Also, I get a very cryptic registration notification.  I think this is a client issue (i.e. not understanding how to present this special "type" of message).  The message (as displayed in the latest JabberiM version) is as follows:
> > >
> > > The user sprint at jabber.dev.sprint.com was just created with the following registration data: <query
> > > xmlns='jabber:iq:register'><resource>Work</resource><name>MyFirstName MyLastName</name><email>myEmail</email><x
> > > xmlns='jabber:x:delay' stamp='20010328T19:26:31'>registered</x></query>
> > >
> > >
> > > Anybody have any ideas, particularly on the error?
> > >
> > > Kevin Hollenshead
> > > Sprint
> > > texasaggie at jabber.com
> > >
> > >
> > >
> > > _______________________________________________
> > > jadmin mailing list
> > > jadmin at jabber.org
> > > http://mailman.jabber.org/listinfo/jadmin
> 
> 
> _______________________________________________
> jadmin mailing list
> jadmin at jabber.org
> http://mailman.jabber.org/listinfo/jadmin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://mail.jabber.org/pipermail/jadmin/attachments/20010329/dfbb2d66/attachment-0005.pgp>


More information about the JAdmin mailing list