[jadmin] Re: jabberd on RH90

Andres Lamouroux alamouro at uvirtual.ean.edu.co
Thu Jan 22 18:32:35 CST 2004


You have to install pth-devel-2.0.0-0.fdr.1.rh90.i386.rpm, it installs
required libraries to configure and to compile jabberd-1.4.3, it worked
fine in both RedHat9 and FedoraCore 1


                 \||/ --pth rulez!!
                 |  @___oo
       /\  /\   / (__,,,,|
      ) /^\) ^\/ _)
      )   /^\/   _)
      )   _ /  / _)
  /\  )/\/ ||  | )_)
 <  >      |(,,) )__)
  ||      /    \)___)\
  | \____(      )___) )___
   \______(_______;;; __;;;


Andrés L'amouroux
alamouro at uvirtual.ean.edu.co
L.R.U. 171841
http://uvirtual.ean.edu.co/iskariote
> I install pth-1.4.0.tar.gz and doesn't work, then I install by rpm
> pth-2.0.0-2.i386.rpm, in that case, the program found pth but, the
> configure do not work fine.  Ant then the jabber doesn't start.
>
> However, I install jabberd v1.4.2, and everything work fine.
>
> Best regards
> Ray
>
>
> -----Original Message-----
> From: jadmin-admin at jabber.org [mailto:jadmin-admin at jabber.org] On Behalf
> Of Frank Seesink
> Sent: Thursday, January 22, 2004 9:44 AM
> To: jadmin at jabber.org
> Subject: [jadmin] Re: jabberd on RH90
>
> Hey Ramon!
>
> Sounds like there's an issue with your GNU Pth installation.  Did you do
>
> all the required steps as documented in GNU Pth?
>
> 	./configure
> 	make
> 	make test
> 	make install
>
> Personally, I'd go get the latest, which is GNU Pth v2.0.0, available
> here:
>
> 	http://www.gnu.org/software/pth/pth.html
>
> There's really no requirement to run 1.4.0 anymore from what I can tell,
>
> assuming you're using jabberd v1.4.3.
>
> Second, if you've done all the above, try the following command and see
> what comes back:
>
> 	pth-config --version
>
> You should get back the version of Pth installed.  If you get a command
> not found error, then either you did not install the binaries using
> 'make install', or else your PATH does not include /usr/local/bin, which
>
> is the default directory to which pth-config, etc., are installed.  Try
> the command
>
> 	/usr/local/bin/pth-config --version
>
> to see if it's there, or just go look in that directory.
>
> In short, jabberd's configure script is simply executing pth-config to
> figure out if it's there.  If it can't find it in your PATH, that would
> explain the errors.
>
>
> Ramon Torres Rojas wrote:
>
>> I have some problems installing jabberd-1.4.3.tar.gz on Red Hat 9.0.
>>
>> When I type  ./configure
>>
>> The program tell the following error
>>
>> Running Jabber Configure
>>
>> ========================
>>
>>
>>
>> Searching for SSL...            Disabled.
>>
>> Support for IPv6...             Disabled.
>>
>> Getting pth settings..../configure: line 1: pth-config: command not
> found
>>
>> ./configure: line 1: pth-config: command not found
>>
>> ./configure: line 1: pth-config: command not found
>>
>> ./configure: line 1: pth-config: command not found
>>
>> ____________________________________________________________
>>
>> GNU Pth (1.4.0 or newer) is not currently installed.
>>
>> GNU Pth is required for building Jabberd.
>>
>> ____________________________________________________________
>>
>>           Error.
>>
>>
>>
>>  No version of Pth is available on this system
>>
>> http://www.gnu..org/software/pth/Setting Build Parameters...     Done.
>>
>> Generating Settings Script...   Done.
>>
>>
>>
>> You may now type 'make' to build your new Jabber system.
>>
>>
>>
>> And I download and install pth, but the error continue.
>>
>> What I supouse to do, anybody have that problems.
>>
>>
>>
>> Best regards
>>
>> Ramon
>
> _______________________________________________
> jadmin mailing list
> jadmin at jabber.org
> http://mailman.jabber.org/listinfo/jadmin
>
>
> _______________________________________________
> jadmin mailing list
> jadmin at jabber.org
> http://mailman.jabber.org/listinfo/jadmin
>





More information about the JAdmin mailing list