[jadmin] setting up jabber with mysql

Gerardo Santana Gómez Garrido gerardo.santana at gmail.com
Thu Aug 4 15:01:13 CDT 2005


On 8/4/05, Julian Opificius <julianop at barnlea.com> wrote:
> Gerardo Santana Gómez Garrido wrote:
> > On 8/4/05, Julian Opificius <julianop at barnlea.com> wrote:
> >
> >>I just restarted jabber.
> >>
> >>This is what got put into the mysql log:
> >>050804 13:11:16      84 Connect     jabberd2 at localhost on jabberd2
> >>050804 13:11:17      85 Connect     jabberd2 at localhost on jabberd2
> >>
> >>This is what got put into c2s.log:
> >>Thu Aug  4 13:11:17 2005 [notice] starting up
> >>Thu Aug  4 13:11:17 2005 [info] process id is 24376, written to
> >>/usr/local/var/jabberd/pid/c2s.pid
> >>Thu Aug  4 13:11:17 2005 [notice] initialised auth module 'mysql'
> >>Thu Aug  4 13:11:17 2005 [notice] [localhost] configured; realm=(null)
> >>Thu Aug  4 13:11:17 2005 [notice] attempting connection to router at
> >>127.0.0.1,port=5347
> >>Thu Aug  4 13:11:17 2005 [notice] connection to router established
> >>Thu Aug  4 13:11:17 2005 [notice] [0.0.0.0, port=5222] listening for
> >>connections
> >>Thu Aug  4 13:11:17 2005 [notice] ready for connections
> >>c2s.log lines 1-8/8 (END)
> >>
> >>And this is what got put into sm.log:
> >>Thu Aug  4 13:11:16 2005 [notice] starting up
> >>Thu Aug  4 13:11:16 2005 [notice] id: localhost
> >>Thu Aug  4 13:11:16 2005 [info] process id is 24359, written to
> >>/usr/local/var/jabberd/pid/sm.pid
> >>Thu Aug  4 13:11:16 2005 [notice] initialised storage driver 'mysql'
> >>Thu Aug  4 13:11:16 2005 [notice] version: jabberd sm 2.0s9
> >>Thu Aug  4 13:11:16 2005 [notice] attempting connection to router at
> >>127.0.0.1,port=5347
> >>Thu Aug  4 13:11:16 2005 [notice] connection to router established
> >>Thu Aug  4 13:11:16 2005 [notice] ready for sessions
> >>
> >>
> >>When I tried to start a new account/connection (username is already in
> >>mysql), this appeared in c2s.log:
> >>Thu Aug  4 13:15:02 2005 [notice] [7] [192.168.100.166, port=1354] connect
> >>Thu Aug  4 13:15:02 2005 [notice] [7] [192.168.100.166, port=1354]
> >>disconnect
> >>
> >>Hope this helps.
> >
> >
> > Certainly.
> >
> >
> >>Julian.
> >
> >
> >
> > Your server seems to work fine. Now enable the XML debug option in
> > your Jabber client and watch what is happening when you try to
> > connect.
> >
> 
> I was trying to use Psi on Windows, but it does not appear to have a
> debug mode. I used Gabber on the actual Linux server itself, and was
> able to connect and set up the account !!!


Psi has an XML Console. Click with the right button below the tool
bar, on the white stripe that has your nickname, select Actions and
then click on XML Console.


> 
> Going back to Psi on Windows I am unsuccessful, and get the same
> connect/disconnect messages as before.
> 
> I'll look for a Windows client that has debug capability. If you know of
> one please suggest it.
> 
> We're close! Thanks for your help so far!
> 
> Julian.

-- 
Gerardo Santana Gómez Garrido
http://www.openbsd.org.mx/santana/
"Entre los individuos, como entre las naciones, el respeto al derecho
ajeno es la paz" -Don Benito Juárez



More information about the JAdmin mailing list