[jadmin] JWChat - Punjab Debug Mode

Gonzalo Barrio gbarrio at novamens.com
Thu Oct 6 16:44:38 CDT 2005


Anyone know how to run the punjab 0.8 service in debug mode.
I have an alert with some users saying "service unavailable" and dous 
not connect.
I trace jwchat and see that punjab return this:


2005/10/06 18:32 ART [HTTPChannel,7,127.0.0.1] Starting factory 
<punjab.session.Session instance at 0xb5f77f6c>
2005/10/06 18:32 ART [XmlStream,client] 127.0.0.1 - - 
[06/Oct/2005:21:32:05 +0000] "POST /httpp/ HTTP/1.1" 200 151 "-" 
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050825 
Firefox/1.0.4 (Debian package 1.0.4-2sarge3)"
2005/10/06 18:32 ART [HTTPChannel,7,127.0.0.1] 127.0.0.1 - - 
[06/Oct/2005:21:32:05 +0000] "POST /httpp/ HTTP/1.1" 200 - "-" 
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050825 
Firefox/1.0.4 (Debian package 1.0.4-2sarge3)"
2005/10/06 18:32 ART [XmlStream,client] 127.0.0.1 - - 
[06/Oct/2005:21:32:07 +0000] "POST /httpp/ HTTP/1.1" 200 123 "-" 
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050825 
Firefox/1.0.4 (Debian package 1.0.4-2sarge3)"
2005/10/06 18:32 ART [XmlStream,client] 127.0.0.1 - - 
[06/Oct/2005:21:32:08 +0000] "POST /httpp/ HTTP/1.1" 200 30 "-" 
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050825 
Firefox/1.0.4 (Debian package 1.0.4-2sarge3)"
2005/10/06 18:32 ART [XmlStream,client] 127.0.0.1 - - 
[06/Oct/2005:21:32:09 +0000] "POST /httpp/ HTTP/1.1" 500 - "-" 
"Mozilla/5.0 (X11; U;Linux i686; en-US; rv:1.7.10) Gecko/20050825 
Firefox/1.0.4 (Debian package 1.0.4-2sarge3)"
2005/10/06 18:34 ART [XmlStream,client] Stopping factory 
<punjab.session.Session instance at 0xb5f77f6c>

The last one is the error 500.

I think is not handling fine the roster iq. because n the jwchat debug 
window appear the roster iq get sended but then this error:

[Thu Oct 6 18:42:08 2005] (level 3) func: JSJaCHandleResponse
xmldoc.firstChild.childNodes.length: 1
[Thu Oct 6 18:42:08 2005] (level 3) func: JSJaCHandleResponse
xmldoc.firstChild.childNodes.item(0).nodeName: iq
[Thu Oct 6 18:42:08 2005] (level 3) func: unknown
handling auth2
[Thu Oct 6 18:42:08 2005] (level 3) func: unknown
incoming event 'onconnect'
[Thu Oct 6 18:42:08 2005] (level 2) func: unknown
handling event 'onconnect'
[Thu Oct 6 18:42:08 2005] (level 0) func: handleConnected
Connected
[Thu Oct 6 18:42:08 2005] (level 3) func: unknown
registered roster_1
[Thu Oct 6 18:42:08 2005] (level 4) func: JSJaCSendQueue
sending: 
2984455a7430443db2fc9976201c9afa;xgGe8dXcJezzm5rgLIbaMX+5Vs8=,<iq 
type="get" id="roster_1"><query xmlns="jabber:iq:roster"/></iq>
[Thu Oct 6 18:42:08 2005] (level 3) func: unknown
unregistered auth2
[Thu Oct 6 18:42:09 2005] (level 4) func: unknown
async recv:
[Thu Oct 6 18:42:09 2005] (level 1) func: JSJaCHPCPrepareResponse
invalid response:
[Thu Oct 6 18:42:09 2005] (level 1) func: JSJaCHPCPrepareResponse
Disconnected.
[Thu Oct 6 18:42:09 2005] (level 3) func: unknown
incoming event 'ondisconnect'
[Thu Oct 6 18:42:09 2005] (level 2) func: unknown
handling event 'ondisconnect'
[Thu Oct 6 18:42:09 2005] (level 3) func: unknown
incoming event 'onerror'
[Thu Oct 6 18:42:09 2005] (level 2) func: unknown
handling event 'onerror'

The invalid response is when arrive the error 500 from punjab.

If I could run punjab in debug mode I think I can fix this, maybe is 
hanlding wrong the roster iq result from the server (jabberd-2s10).

Thanks in advance.

Gonzalo Barrio Linares.




More information about the JAdmin mailing list