[JDEV] Mysql and transports

Rodrigo Roman dedalo at ferengi.com.ar
Mon Jan 28 06:13:39 CST 2002


Continuing...
 
I cannot make any transport work with mysql...
 
Myslq is working form jabber and if I coneect to msn it create my roster in
usersroster...
 
but nothing is saved in the msn or aim tables (my login information for the
transport inst' it?)
 
it keeps triyng to set the infromation, this line appears all the time...
 
Mon Jan 28 09:06:17 2002  deliver.c:460 DELIVER 2:aim.ferengi.com.ar <xdb
type='set' to='ec75fec87fc620cd7262b4072aceb62397534071 at aim.ferengi.com.ar'
<mailto:to='ec75fec87fc620cd7262b4072aceb62397534071 at aim.ferengi.com.ar'>
from='aim.ferengi.com.ar' ns='aimtrans:roster'
id='3'><aimtrans><buddies/></aimtrans></xdb>
Mon Jan 28 09:06:17 2002  deliver.c:649 delivering to instance 'xdb'
Mon Jan 28 09:06:17 2002  xdb_sql.c:124 modules = 814b8e0
Mon Jan 28 09:06:28 2002  mio.c:698 MIO read from socket 19: <log
type='warn' from='sessions.c:1100'>[AT] Closing down session for
<mailto:dedalo at poseidon.ferengi.com.ar/hermes>
dedalo at poseidon.ferengi.com.ar/hermes</log>
 
 
I'm not sure about something... in the to line I have:
ec75fec87fc620cd7262b4072aceb62397534071  this code, must be the same tha
appears in users0k table?
 
thanks for any help!
 
-----Mensaje original-----
De: Rodrigo Roman [mailto:dedalo at ferengi.com.ar] 
Enviado el: Viernes, 25 de Enero de 2002 06:45 p.m.
Para: 'jdev at jabber.org'
Asunto: RE: [JDEV] Mysql and transports


Something odd is happening...
 
I used your sql to create tables, and your xml.
Then I tried with my instalation of msnt, and worked out... but only the
first time, when I register the gateway, i received all my roster form msn
and could send and receive messages. Then when I log in again it does not
recive my presence... gateway does not come alive...
 
I tried with your msntrans... and the same... I could register and received
my contacts.. but receive this error:
Fri Jan 25 18:44:23 2002  deliver.c:460 DELIVER 4:c2s <route
from='dedalo at poseidon.ferengi.com.ar/8252928'
<mailto:from='dedalo at poseidon.ferengi.com.ar/8252928'>
<mailto:to='21 at c2s/819B518'> to='21 at c2s/819B518'><presence
from='msn.ferengi.com.ar/registered'
to='dedalo at poseidon.ferengi.com.ar/Winjab'
<mailto:to='dedalo at poseidon.ferengi.com.ar/Winjab'>
type='error'><status>Online</status><error code='500'>Internal Server
Error</error></presence></route>
Fri Jan 25 18:44:23 2002  deliver.c:649 delivering to instance 'c2s'
Fri Jan 25 18:44:23 2002  client.c:148 C2S:
dedalo at poseidon.ferengi.com.ar/8252928
<mailto:dedalo at poseidon.ferengi.com.ar/8252928>  has an active session,
delivering packet
Fri Jan 25 18:44:23 2002  client.c:202 Writing packet to MIO: <presence
from='msn.ferengi.com.ar/registered'
to='dedalo at poseidon.ferengi.com.ar/Winjab'
<mailto:to='dedalo at poseidon.ferengi.com.ar/Winjab'>
type='error'><status>Online</status><error code='500'>Internal Server
Error</error></presence>
Fri Jan 25 18:44:23 2002  mio.c:908 mio_write called on x: 82728A8 buffer:
(null)
Fri Jan 25 18:44:23 2002  mtq 81AD7D8 leaving to pth
Fri Jan 25 18:44:23 2002  mio.c:268 write_dump writing data: <presence
from='msn.ferengi.com.ar/registered'
to='dedalo at poseidon.ferengi.com.ar/Winjab'
<mailto:to='dedalo at poseidon.ferengi.com.ar/Winjab'>
type='error'><status>Online</status><error code='500'>Internal Server
Error</error></presence>
 
any help?
 
-----Mensaje original-----
De: Jason Reineri [mailto:jreineri at northridge.com] 
Enviado el: Viernes, 25 de Enero de 2002 11:50 a.m.
Para: jdev at jabber.org
Asunto: RE: [JDEV] Mysql and transports


We are running a version of the MSN transport here that works with xdb_sql.
If you'd like to run it I can email a tarball to you, but it won't be easy
to set up.  There are quite a few things you have to do to xdb_sql before it
will work with it.  You'll have to add a table to your mySQL db, add query
definitions to the xdb_sql.xml file and there was a bug in xdb_sql that
prevented the msn transport from working correctly with it that we fixed.  I
don't know if this bug has been fixed in the newest version of xdb_sql or
not.  The bug was due to the fact that the msn transport sends values to xdb
as attributes of an xml tag instead of as children tags I think.  It may
have been the other way around.  This functionality was broken in version
1.1 of xdb_sql, if it was fixed I'm sure the maintainer will chime in.  If
it hasn't been fixed I need to send him our fix.  If you want to give it a
shot let me know.  Just realize that it will be pretty complicated.
 
Jason Reineri
Northridge Systems, Inc.
 
-----Original Message-----
From: Rodrigo Roman [mailto:dedalo at ferengi.com.ar] 
Sent: Friday, January 25, 2002 7:58 AM
To: 'jdev at jabber.org'
Subject: [JDEV] Mysql and transports
 
I have installes xdb_sql succesfully? 
Everything is working but transports, I cannot make MSN nor AIM to work,
winjab disconnects when I try to browse the agent... and then it hangs...
with colinjab is the same, and psi for linux also...
With jabber users everything is fine... 
Any clue? 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20020128/4844cd04/attachment-0002.htm>


More information about the JDev mailing list