[jdev] tls + plain sasl not working

Adrian Adrian flashbk2003 at yahoo.com
Wed Mar 22 05:29:04 CST 2006


I used that too : 
  <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl'mechanism='PLAIN'/>

  I inserted the space just to see if it makes any difference. 
  The interesting thing is that if I try :
  <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl'mechanism='DIGEST-MD5'/>
  server sends me a challenge instead of failure.
  
  But I don't want to go through that  MD5 jungle. 
  
  
  
Norman Rasmussen <norman at rasmussen.co.za> wrote:  shouldn't:be

<auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl'mechanism='PLAIN'/>

are you missing the space?

On 3/22/06, Adrian Adrian  wrote:
> Hello,
>
>  I want to comunicate with and IM server (Wildfire) through TLS on port 5222
> using SASL plain text authentication according to RFC 3920
>
>  Basically I start a stream, server shows me the auth mechanisms, I send
> startls command, server says proceed, I start a new stream, server shows me
> the auth mechanisms, I select PLAIN and the server shuts me off.
>
>
>  Here's the communication :
>
>  CLIENT : 
> xmlns="jabber:client"
> xmlns:flash="http://www.jabber.com/streams/flash"
> version="1.0">
>  SERVER  
> xmlns:flash="http://www.jabber.com/streams/flash"
> xmlns:stream="http://etherx.jabber.org/streams"
> xmlns="jabber:client" from="192.168.11.3" id="5bbdf7a3" xml:lang="en"
> version="1.0">
> xmlns="urn:ietf:params:xml:ns:xmpp-tls">
> xmlns="urn:ietf:params:xml:ns:xmpp-sasl">CRAM-MD5DIGEST-MD5PLAINANONYMOUS
> xmlns="http://jabber.org/features/iq-auth"/>
> xmlns="http://jabber.org/features/iq-register"/>
>  CLIENT 
>  SERVER 

>  CLIENT 
> xmlns="jabber:client"
> xmlns:flash="http://www.jabber.com/streams/flash"
> version="1.0">
>  SERVER 
> xmlns:flash="http://www.jabber.com/streams/flash"
> xmlns:stream="http://etherx.jabber.org/streams"
> xmlns="jabber:client" from="192.168.11.3" id="e6661ae8" xml:lang="en"
> version="1.0">
> xmlns="urn:ietf:params:xml:ns:xmpp-tls">
> xmlns="urn:ietf:params:xml:ns:xmpp-sasl">CRAM-MD5DIGEST-MD5PLAINANONYMOUS
> xmlns="http://jabber.org/features/iq-auth"/>
> xmlns="http://jabber.org/features/iq-register"/>
>  CLIENT 
> xmlns='urn:ietf:params:xml:ns:xmpp-sasl'mechanism='PLAIN'/>
>  SERVER 
> xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
>
>  As you can see, although the server advertises the PLAIN mechanism, it
> doesn't let me connect to it. Why ?
>
>  Thanks.
>
>  PS here's the wildfire error log :
>
>
>
>
>
>
>
>  ________________________________
> Yahoo! Mail
>  Bring photos to life! New PhotoMail makes sharing a breeze.
>
>


--
- Norman Rasmussen
 - Email: norman at rasmussen.co.za
 - Home page: http://norman.rasmussen.co.za/



		
---------------------------------
Yahoo! Travel
 Find  great deals to the top 10 hottest destinations!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20060322/e24fe751/attachment-0002.htm>


More information about the JDev mailing list