[jdev] tls + plain sasl not working

Adrian Adrian flashbk2003 at yahoo.com
Wed Mar 22 07:23:45 CST 2006


Good point. 
  One more question:  In which format should I send the base64 information ? 
  I tried : 
  <auth  xmlns="urn:ietf:params:xml:ns:xmpp-sasl"mechanism="PLAIN">'+Base64.Encode("<username>adi</username><password>secret</password>")+"</auth>
  
I guess the nodes <username> and <password> are not the  right ones but I can't find anywhere the right syntax for the auth  node. 
  
  Thank you. 
  
Norman Rasmussen <norman at rasmussen.co.za> wrote:  you should be sending:


    
<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl"
mechanism="PLAIN">{base64 data here}</auth>
  

That's the way PLAIN works,  DIGEST-MD5 doesn't have an initial client
to server payload, so that's why it's empty in the examples.

On 3/22/06, Adrian Adrian  wrote:
> Hey Normann,
>
>  No, I don't think so.
>  According to the xmpp RFC3920 specifications
> (http://www.xmpp.org/specs/rfc3920.html#tls )
>  I need to select the mechanism first. The credentials are sent through an
> iq packet after the negotiation ended.
>
>  Adrian.
>
>
>
>
>
>
>
>
> Norman Rasmussen  wrote:
>
> shouldn't you be sending the PLAIN data in the auth request? i.e.
> take the username and password, base64 encode them, and send them as
> part of the auth stanza.
>
> --
> - Norman Rasmussen
>  - Email: norman at rasmussen.co.za
>  - Home page: http://norman.rasmussen.co.za/
>
>
>
>  ________________________________
> Yahoo! Mail
>  Bring photos to life! New PhotoMail makes sharing a breeze.
>
>


--
- Norman Rasmussen
 - Email: norman at rasmussen.co.za
 - Home page: http://norman.rasmussen.co.za/


		
---------------------------------
 Yahoo! Mail
 Use Photomail to share photos without annoying attachments.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20060322/568a63fa/attachment-0002.htm>


More information about the JDev mailing list