[jadmin] FW: ICQ Transport problems

Leslie Seigneur les at uark.edu
Tue Mar 13 11:27:50 CST 2001

Not sure if I should be posting this question to this particular list but I am
looking for help anywhere I can find it.  Please let me know if this kind of
post is inappropriate for this list.
I am somewhat new to Jabber and am trying to setup transports.  I am having
trouble with the ICQ transport.  I am running Jabber server 1.4 on Solaris 2.8.
I downloaded the ICQ transport from http://download.jabber.org/dists/1.4/final/
The make seemed to run just fine, it created the icqtrans.so file in the
directory.  I edited the jabber.xml file as instructed at
http://docs.jabber.org/no-sgml/howto-1.4.html#icq and I also tried to use the
code in the README file for the icq-transport.  The problem that I am seeing
occurs when I try to register the service using JabberIM or WinJabber.
I type in my ICQ username and password in the Service Registration screen and
click Next.  This seems to take the Jabber Server down.  I am running jabberd
in debug mode and here is what I see when I try to register the ICQ transport.

Mon Mar 12 10:21:53 2001  deliver.c:649 delivering to instance 'icq.arachne'
Mon Mar 12 10:21:53 2001  unknown.c:84 Packet from unknown user
'les at arachne.uark.edu/Work'
Mon Mar 12 10:21:53 2001  session.c:31 Creating session for
les at arachne.uark.edu/Work
Mon Mar 12 10:21:53 2001  mtq.c:78 MTQ(new)
Mon Mar 12 10:21:53 2001  mtqoverflow 0 overflowing 20C1A0
Mon Mar 12 10:21:53 2001  mtq 11C820 queue call 20C1A0
Mon Mar 12 10:21:53 2001  session.c:71 Session[les at arachne.uark.edu], starting
Mon Mar 12 10:21:53 2001  mio_server.c:34 server_connect
Mon Mar 12 10:21:53 2001  mio_server.c:65 - our local IP address is
Mon Mar 12 10:21:53 2001  mio_peer.c:188 Port range = [2000,3000], start at
Mon Mar 12 10:21:53 2001  mio.c:1092 io_select to listen on 2000
Mon Mar 12 10:21:53 2001  mio.c:1116 io_select starting to listen on 2000
Bus Error (core dumped)
[/export/home/jabber/jabber/server/jabber-1.4:60]Mon Mar 12 10:21:53 2001
dnsrv.c:143 dnsrv: Read error on coprocess(1): 0 Error 0
Mon Mar 12 10:21:53 2001  dnsrv.c:157 DNSRV CHILD: out of loop.. exiting normal


My ID on the jabber server is les at arachne.uark.edu.

Is there and issue with the current icq transport and Jabber server 1.4?

Here are the fragments in jabber.xml.  As you can see I am not currently using
a fully qualified domain name but this has worked for the AIM transport.

   <service type="icq" jid="icq.arachne" name="ICQ Transport">

<service id="icq.arachne">
   <icqtrans xmlns="jabber:config:icqtrans">
      <!-- This tag contains the message displayed to users at registration
time. -->
      <instructions>Please enter your ICQ number (in the "username" field),
                    nickname, and password.  Leave the "username" field blank
                    to create a new ICQ number.</instructions>
      <!-- contains the message displayed when users search ICQ Transport. -->
      <search>Search for ICQ users</search>
     <!-- Contains the vCard of this transport. -->
        <FN>ICQ Transport</FN>
        <DESC>This is ICQ Transport</DESC>
      <!-- This should be a prime number close to the amount of concurrent
users you expect to                                 have. -->
      <!--Use this to control the port range ICQ will use to listen for new TCP
connections. -->

Any suggestions will be very much appreciated!

Les Seigneur
University of Arkansas
Computing Services
les at uark.edu

More information about the JAdmin mailing list