[jadmin] jabberd shutdown after I close telnet session

Fernando Medina, Jr. fmedina at nic.pibnet.com
Tue Mar 20 14:43:08 CST 2001

That's how I send it to bg always, except I don't use -D.  I just tried it and it was gone after I closed telnet session.  Very strange.. RH 6.2, any ideas?
    -----Original Message-----
    From: Chris McDonald <phx-jabber at mindspring.com>
    To: jadmin at jabber.org <jadmin at jabber.org>
    Date: Tuesday, March 20, 2001 2:34 PM
    Subject: RE: [jadmin] jabberd shutdown after I close telnet session
    Try executing the server with this command:

    ./jabberd –D &


    That will make the process run in the background


    If you’d like to be able to telnet back in later and observe the server, then use “screen”.  It lets you run a terminal within a terminal and you can just reattach to it after you open a new telnet session.  Run: man screen for more info.


    Chris McDonald

    phx-jabber at mindspring.com

    Jabber Admin


    -----Original Message-----
    From: jadmin-admin at jabber.org [mailto:jadmin-admin at jabber.org]On Behalf Of Fernando Medina, Jr.
    Sent: Tuesday, March 20, 2001 1:16 PM
    To: jadmin at jabber.org
    Subject: [jadmin] jabberd shutdown after I close telnet session


    I start jabberd with my username, send it to bg and it runs finw while I am still logged into machine.  When I close my telnet session the server ends, leaving it's pid file in the dir.  Why does it close?  Also, I am still getting messages saying ti cannot communicate with jabber.org.  It is not supposed to, it will be completely for internal communications, no connection to Internet is desired.  The connection exists, but we use NAT and the outside address does not resolve to internal server name:


    20010320T17:53:30: [alert] (s2s): We were told by update.jabber.org that our sending name dns01.SOMEWHERE.com is invalid, either something went wrong on their end, we tried using that name improperly, or dns does not resolve to us 


    20010320T17:53:30: [notice] (update.jabber.org): bouncing a packet to jsm at update.jabber.org/1.4 from dns01.SOMEWHERE.com: Server Connect Failed


    Can I get rid of that?  thanks,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jadmin/attachments/20010320/bc14d9e3/attachment-0001.htm>

More information about the JAdmin mailing list