[jadmin] troubles with ./configure --enable-pam

Joe A. Chapman jchapman at mndaily.com
Thu Oct 13 19:02:21 CDT 2005

Hey everyone,
I seem to be having some major issues with configuring jabber to use PAM
for authentication.

I run the configure command:

# ./configure --enable-pam --enable-mysql --disable-ssl --enable-pipe

and I get this:




checking for vsnprintf... yes

checking if snprintf can handle NULL arguments... yes

checking if vsnprintf can handle NULL arguments... yes

checking stringprep.h usability... yes

checking stringprep.h presence... yes

checking for stringprep.h... yes

checking for stringprep_check_version in -lidn... yes

checking for Libidn version >= 0.3.0... yes

checking mysql.h usability... no

checking mysql.h presence... no

checking for mysql.h... no

checking for mysql.h in /usr/include/mysql... yes

checking for mysql_init in -lmysqlclient... yes

checking security/pam_appl.h usability... no

checking security/pam_appl.h presence... no

checking for security/pam_appl.h... no

configure: error: PAM application libraries not found


Then the configuration ends. I have PAM installed and configured (I am
currently using it for SSH logins to the system, so I know its working)


I have tried also with "-with-extra-library-path=/lib/security/"

As well as "-with-extra-library-path=/etc/pam.d/"

To no avail. I have been looking around the internet for some answers
but can't seem to find anything like this...

I am running RHEL 3.1



I tried configuring it with the "--enable-authreg=pam" but from it looks
like from what I've read that option is no longer valid. When I
configure with that option the install goes fine, but when I try to
start the server I get this in my c2s.log file:
"...[error] no such auth module 'pam'"
Any help would be greatly appreciated!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jadmin/attachments/20051013/ba55a241/attachment-0003.htm>

More information about the JAdmin mailing list