[jadmin] troubles with ./configure --enable-pam

Williams, Kevin C kevin.c.williams3 at boeing.com
Thu Oct 13 19:05:12 CDT 2005

Just out of curiosity, why are you disabling ssl?  With PAM auth, you
must enable sending plaintext passwords and this is bad.  I do the same
as you on a redhat fc2 box and the only difference was the disable-ssl.


	From: Joe A. Chapman [mailto:jchapman at mndaily.com] 
	Sent: Thursday, October 13, 2005 5:02 PM
	To: jadmin at jabber.org
	Subject: [jadmin] troubles with ./configure --enable-pam

	Hey everyone,
	I seem to be having some major issues with configuring jabber to
use PAM for authentication.

	I run the configure command:

	# ./configure --enable-pam --enable-mysql --disable-ssl

	and I get this:




	checking for vsnprintf... yes

	checking if snprintf can handle NULL arguments... yes

	checking if vsnprintf can handle NULL arguments... yes

	checking stringprep.h usability... yes

	checking stringprep.h presence... yes

	checking for stringprep.h... yes

	checking for stringprep_check_version in -lidn... yes

	checking for Libidn version >= 0.3.0... yes

	checking mysql.h usability... no

	checking mysql.h presence... no

	checking for mysql.h... no

	checking for mysql.h in /usr/include/mysql... yes

	checking for mysql_init in -lmysqlclient... yes

	checking security/pam_appl.h usability... no

	checking security/pam_appl.h presence... no

	checking for security/pam_appl.h... no

	configure: error: PAM application libraries not found


	Then the configuration ends. I have PAM installed and configured
(I am currently using it for SSH logins to the system, so I know its


	I have tried also with "-with-extra-library-path=/lib/security/"

	As well as "-with-extra-library-path=/etc/pam.d/"

	To no avail. I have been looking around the internet for some
answers but can't seem to find anything like this...

	I am running RHEL 3.1



	I tried configuring it with the "--enable-authreg=pam" but from
it looks like from what I've read that option is no longer valid. When I
configure with that option the install goes fine, but when I try to
start the server I get this in my c2s.log file:
	"...[error] no such auth module 'pam'"
	Any help would be greatly appreciated!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jadmin/attachments/20051013/a4aa6e3b/attachment-0004.htm>

More information about the JAdmin mailing list