[jadmin] Ejabberd + Proxy65

Peter Saint-Andre stpeter at jabber.org
Fri Sep 29 13:24:24 CDT 2006

AFAIK, the CVS version of proxy65 will not work with twisted 2.x (at
least according to the reports I've received). It's close to working but
I haven't carved out the time to test it fully. My bad.


Matt Gibson wrote:
> Hi All,
> I am running Ejabberd CVS from about 3 days ago. I haven't tried 1.1.2
> yet, but will be later this weekend.
> My question is - does anyone have proxy65 working on a "current" linux box?
> Here are the versions of software I am using:
> - Python 2.4.3 (#1, Sep 20 2006, 05:40:42)
> - [GCC 4.1.1 (Gentoo 4.1.1)] on linux2
> - twistd (the Twisted daemon) 2.0.1
> - ejabberd CVS from Sept 28th 2006
> - proxy65 (both release from 2003, and what's in the cvs from 10
> months ago approx)
> Here is what I did. I opened up port 7777 on the firewall.
> Then I made the tap file for proxy65 with this line:
> mktap proxy65 --jid=proxy --secret=secret --rhost=
> --rport=6000 --proxyips=64.246.XXX.XXX:7777
> I also tried:
> mktap proxy65 --jid=proxy.chat.mydomain.com --secret=secret
> --rhost= --rport=6000 --proxyips=64.246.XXX.XXX:7777
> Then I added this to Ejabberd's configuration file:
> {6000, ejabberd_service, [{access, all}, {host, "proxy", [{password,
> "secret"}]}]}]}.
> I also tried:
> {6000, ejabberd_service, [{access, all}, {hosts,
> ["proxy.chat.mydomain.com"], [{password, "secret"}]}]}]}.
> Then I started Ejabberd, then I ran mktap -no -f proxy65.tap
> Neither seem to work. I've also tried just about every combination of
> the ejabber and mktap lines possible, and none work, some get closer
> than others, but non actuallly work.
> The client I am using is PSI CVS, and I set it in "account settings"
> for "file transfer proxy". I did not set the "proxy and port" options
> in the "psi options" as that seems to be systemwide setting, not per
> server setting.
> The closest we have gotten to working, is on my end the file says it's
> tranferred, but at the other end psi says it could not connect to
> remote host.
> I have a feeling it's due to the newer versions of software at use,
> but I am not sure.
> Any help would be appreciated!
> Matt Gibson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 7358 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://mail.jabber.org/pipermail/jadmin/attachments/20060929/1e6759a6/attachment-0001.bin>

More information about the JAdmin mailing list