[JDEV] JabberBeans

Matt Diez matt at vedalabs.com
Thu Apr 12 17:52:04 CDT 2001


Yep, 
  I'm probably going to hell for not reporting this through the proper
channels, but I think I've stumbled across a bug in JabberBeans.
When Jabber sends the following packet:

<xdb type='set' action='insert' to='user at elavil' from='sessions'
ns='jabber:x:offline' id='905'>
	<message id='JCOM_19' to='user at elavil' from='gez at elavil/Desktoppy'>
		<thread>C1E549CFFDE38C48BB550A3EB994AA13</thread>
		<subject>2</subject>
		<body>www</body>
		<x xmlns='jabber:x:delay' from='user at elavil'
stamp='20010412T22:39:51'>Offline Storage</x>
	</message>
</xdb>

JabberBeans seems to lose the "action" attribute.

<xdb to="user at elavil" from="sessions" id="905" type="set"
ns="jabber:x:offline">
	<message to="user at elavil" from="glattdiez at elavil/Desktoppy"
id="JCOM_19">
		<subject>2</subject>
		<thread>C1E549CFFDE38C48BB550A3EB994AA13</thread>
		<body>www</body>
		<x xmlns="jabber:x:delay" stamp="20010412T22:39:51"
from="user at elavil">Offline Storage</x>
	</message>
</xdb>

Just to call it to your attention.

Thanks for your work on JabberBeans so far, it's coming along quite nicely.

By the way, are you planning on making some sort of Offline extension class
to handle
serialization of the <offline> tags necessary in the xdb response? currently
I'm just
using my own extension wrapper class to do that.



Take care,
Matthew D. Diez
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20010412/e49ffc33/attachment-0002.htm>


More information about the JDev mailing list