[JDEV] RE: AIX compilation of jabber server.

David Clissold cliss at austin.ibm.com
Thu Feb 1 12:23:12 CST 2001


It's happened to me too; I just downloaded and built
1.4pre2 and go the same result.  This had worked perfectly
for the 1.2 server.
I used the same time.h workaround, but just in jabberd/lib/lib.h.
It compiled cleanly.

As an quick experiment (realizing there may be functional
incompatabilities) I tried the 1.2 *.so modules with the
1.4pre2 jabberd executable and got the same result.  But
the 1.2 jabberd executable was able to load the 1.4pre2 *.so's.

I'll look into it more and see what I can figure out.

I assume that there is not a new libjabber or libxode being released
with 1.4?  I didn't see any on download.jabber.org.

David Clissold 
cliss at austin.ibm.com

>Have you been successful will compiling 1.4pre1?
>This is my process, and I'm quite at a standstill.
>Here's the status
>1) I added all of the compile time flags (specified by David Clissord on
>JDEV) to configure
>    AIX)
>        MCFLAGS="$MCFLAGS -Wl,-G"
>        LIBS="$LIBS -lxode -ljabber"
>        XLDFLAGS="$XLDFLAGS -Wl,-brtl -Wl,-bexpall";;
>2) I ran configure
>3) I added the following
>#ifdef _AIX
>#include <time.h>
>to jsm/modules/mod_time.c and jabberd/lib/jutil.c
>4) I ran make. It compiled.
>5) I ran jabberd, and got the following.
>Loading ./pthsock/pthsock_client.so failed: ''
>Invalid Configuration in instance 'c2s':
>    <load>
>      <pthsock_client>./pthsock/pthsock_client.so</pthsock_client>
>    </load>
>Matthew Diez

More information about the JDev mailing list