[JDEV] RE: AIX compilation of jabber server.

Matt Diez matt at vedalabs.com
Thu Feb 1 13:30:12 CST 2001


David,

Yes, I put in 1.2's pthsock_client.so and got past loading
of that, but it failed on loading the .so for dialback.

If you look at it, xdb_file compiles the exact same way
as pthsock, (same libraries, etc), but xdb_file
loads successfully. 

It strikes me as a symbol import/export resolution problem
but, I can't seem to pick out why 1.2 works just fine.

Matthew D. Diez

-----Original Message-----
From: David Clissold [mailto:cliss at austin.ibm.com]
Sent: Thursday, February 01, 2001 12:23 PM
To: jdev at jabber.org
Subject: [JDEV] RE: AIX compilation of jabber server.


Matt,

It's happened to me too; I just downloaded and built
1.4pre2 and go the same result.  This had worked perfectly
for the 1.2 server.
I used the same time.h workaround, but just in jabberd/lib/lib.h.
It compiled cleanly.

As an quick experiment (realizing there may be functional
incompatabilities) I tried the 1.2 *.so modules with the
1.4pre2 jabberd executable and got the same result.  But
the 1.2 jabberd executable was able to load the 1.4pre2 *.so's.

I'll look into it more and see what I can figure out.

I assume that there is not a new libjabber or libxode being released
with 1.4?  I didn't see any on download.jabber.org.

David Clissold 
cliss at austin.ibm.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20010201/c49ec4f0/attachment-0002.htm>


More information about the JDev mailing list