[JDEV] removing a Yahoo transport registration

Aditya Tyagi atyagi at rapidmedianetwork.com
Sun Jul 15 18:06:28 CDT 2001


Hello,

I have a jabber server setup with a Yahoo transport installed. I used Winjab to assign a username/password to this transport so that I could use it to talk to my buddies. However, I cannot delete my registration (as I can with other transports) and I get the following debug XML output when I try to do this:

SENT: <iq type="get" id="JCOM_114" to="yahoo.rapidbrowser.com"><query xmlns="jabber:iq:register"></query></iq>
RECV: <iq type='result' id='JCOM_114' to='atyagi1 at jabber.rapidbrowser.com/Winjab' from='yahoo.rapidbrowser.com'><query xmlns='jabber:iq:register'><username>aditya_tyagi</username><password/><key>bc5ba6400b62cc503cc41f6ab678f87ae5e10919</key><instructions>Enter your YAHOO! Messenger Username and Password.</instructions><registered/></query></iq>
SENT: <iq id="JCOM_115" to="yahoo.rapidbrowser.com" type="set"><query xmlns="jabber:iq:register"><remove/><key>bc5ba6400b62cc503cc41f6ab678f87ae5e10919</key></query></iq>
RECV: <message to='atyagi1 at jabber.rapidbrowser.com/Winjab' from='yahoo.rapidbrowser.com' type='error'><error code='406'>You have to send both a password AND a username to register with Yahoo! Transport</error></message>
RECV: <iq id='JCOM_115' to='atyagi1 at jabber.rapidbrowser.com/Winjab' type='result' from='yahoo.rapidbrowser.com'/>


Does anyone know if this is a general transport issue or something specific to my installation? (I tried doing this on jabber.org, but was unable to even get the first RECV statement, thus stopping my progress, so I am not sure about that yet...)

I would appreciate any help. Thank you.


Aditya
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20010715/58da63ef/attachment-0002.htm>


More information about the JDev mailing list