[JDEV] Using Java Socket and JAXP1.1 DefaultHandler

Robert Temple Robert.Temple at dig.com
Tue Oct 9 16:05:27 CDT 2001


This happened to me.   I ended up using the Crimson package, its an
implementation of JAXP1.1 by the apache group.   
That worked fine: http://xml.apache.org/crimson/index.html
<http://xml.apache.org/crimson/index.html> 
 
I also had this same problem using MSXML3 & COM.   I couldn't use another
package for that, so I added a hack that
inserted <!-- --> into the stream after reading the <stream:stream> tag.
That forced MSXML to fire a start element event.
 
Good Luck,
 
-Robert

-----Original Message-----
From: John Bell [mailto:johnbell at telus.net]
Sent: Monday, October 08, 2001 11:17 PM
To: jdev at jabber.org
Subject: [JDEV] Using Java Socket and JAXP1.1 DefaultHandler


Hi,
I'm having a problem using the Java Socket object and the JAXP1.1 SAXParser
DefaultHandler. To post all the code would make for a really long post so
I'm hoping an explaination will be sufficient. I connect ok to jabber.org
but it seems that my handler for the <stream:stream> element doesn't get
processed by the parser until the end element is captured, i.e. by sending
"</stream:stream>" to the server, making it impossible to capture the
initialization success event (by processing the <stream:stream> starting
element) and thus making it impossible to process an xml conversation. Has
anyone one seen this or I am I doing something wrong along the way
somewhere.
 
Thanks, John
 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20011009/56da48d6/attachment-0002.htm>


More information about the JDev mailing list