[JDEV] c2s fails on any client's connect

Robert Norris rob at cataclysm.cx
Mon Jan 6 16:46:59 CST 2003


> I'm trying to run jabberd 2.0.0-a3. It starts OK but whenever a client (I'm 
> using Everybuddy) connects, c2s dies, taking the whole server with it. In 
> the syslog I just see "c2s ... offline" and that's it. I tried commenting 
> out the <register/> but it doesn't make a difference. How do I increase the 
> level of debug information provided by the jabberd services.

Compile with --enable-debug then run c2s with the -D switch.

> Also, is there any (incomplete) implementation of ldap auth module at all 
> that I could use? I'd put some coding in to make it work, I'm just hesitant 
> to start from scratch.

I've attached my LDAP module, which is based on the old jabberd 1.5
work. Its untested, and may not even compile. It will go into CVS once
Debian gets OpenLDAP 2.1 into unstable, which will resolve dependency
issues with libsasl, libsasl2 and libldap2.

Rob.

-- 
Robert Norris                                       GPG: 1024D/FC18E6C2
Email+Jabber: rob at cataclysm.cx                Web: http://cataclysm.cx/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: authreg_ldap.c
Type: text/x-csrc
Size: 6388 bytes
Desc: not available
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20030107/1493e917/attachment-0002.c>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20030107/1493e917/attachment-0002.pgp>


More information about the JDev mailing list