[jdev] jabberSMTP

Jon Scottorn jscottorn at possibilityforge.com
Thu Dec 15 16:32:17 CST 2005


Ok, now I don't get any errors but my jabber message is still not coming
through, all I get is:

03:29:26 PM] *** jabbermail is Online [forwarding email]
[03:29:26 PM] *** jabbermail is Offline

Not the email that I sent.

Any other thoughts?

Thanks for all the help

On Fri, 2005-12-16 at 00:14 +0200, Norman Rasmussen wrote:

> change
> 
> my $jabmsg->SetMessage(
> 
> to
> 
> $jabmsg->SetMessage(
> 
> and it'll all work.
> 
> On 12/16/05, Jon Scottorn <jscottorn at possibilityforge.com> wrote:
> >            That is what I have already: here is my smtp2jabber.pl
> >
> >  # Remove the attachment(s) from the message
> >  my $stripper = Mail::Message::Attachment::Stripper->new($msg);
> >  my Mail::Message $textonly  = $stripper->message;
> >  my $body = $textonly->body;
> >
> >  # Connect to jabber
> >  my $jabber = &setup_Jabber(SERVER, PORT, USERNAME, PASSWORD, RESOURCE, "normal/forwarding email");
> >
> >  # Compose the message
> >  my $jabmsg = Net::Jabber::Message->new();
> >
> >  my $jabmsg->SetMessage(
> >                "to"      => "$rcpt",
> >                "subject" => "$sender emailed: $subject",
> >                "body"    => "$body");
> >
> >  # And send it
> >  $jabber->Send($jabmsg);
> >
> >  # Close the connection and exit
> >  $jabber->Disconnect();
> >  exit(0);
> >
> >  What part is messed up?
> >
> >  Thanks
> >
> >
> >  On Thu, 2005-12-15 at 23:29 +0200, Norman Rasmussen wrote:
> >  ahh, had to actually get this working on my dev box.  It needs to be:
> >
> > # Compose the message
> > my $jabmsg = Net::Jabber::Message->new();
> >
> > $jabmsg->SetMessage(
> >              "to"      => "$rcpt",
> >              "subject" => "$sender emailed: $subject",
> >              "body"    => "$body");
> >
> >
> > I think this would be much cooler with a full smtp transport gateway
> > idea, but this works for now.
> >
> > On 12/15/05, Jon Scottorn <jscottorn at possibilityforge.com> wrote:
> > >            Still get same error
> > >
> > >  here is what shows up in jabber
> > >
> > >  [01:40:20 PM] *** jabbermail is Online [forwarding email]
> > >  [01:40:20 PM] *** jabbermail is Offline
> > >
> > >  Don't know if that helps
> > >
> > >
> >
> > --
> > - Norman Rasmussen
> >  - Email: norman at rasmussen.co.za
> >  - Home page: http://norman.rasmussen.co.za/
> >
> >
> >   Jon Scottorn
> >  Systems Administrator
> >  The Possibility Forge, Inc.
> >  http://www.possibilityforge.com
> >  435.635.0591 x.1004
> 
> 
> 
> --
> - Norman Rasmussen
>  - Email: norman at rasmussen.co.za
>  - Home page: http://norman.rasmussen.co.za/

Jon Scottorn
Systems Administrator
The Possibility Forge, Inc.
http://www.possibilityforge.com
435.635.0591 x.1004
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20051215/0c53f5a3/attachment-0002.htm>


More information about the JDev mailing list