[jdev] Re: Re: [jadmin] Problem building jabber-1.4.1

Lars Sommer im at powerdise.com
Wed Mar 14 16:17:31 CDT 2007

Hi Matthias and Norman.

Thank you so much! I got it working now! I can start the jabberd file
from the /jabber/bin location now, i still get the segmentation fault of
course, but now I can debug it :)

I debug it like this:

[root at localhost bin]# gdb jabberd 
(gdb) run
Starting program: /jabber/bin/jabberd 
20070314T21:12:11: [notice] (-internal): initializing server
(this is where i send the create-user-acount xml string from a telnet
Program received signal SIGSEGV, Segmentation fault.

0x00000001 in ?? ()
(gdb) bt
#0  0x00000001 in ?? ()
#1  0x6fffffff in ?? ()
#2  0x00000098 in ?? ()
#3  0x00cc5f18 in xdb_file_phandler (i=0x96a5148, p=0x97ad128,
arg=0x96a86e0) at xdb_file.c:291
#4  0x0082020f in deliver_instance (i=0x96a5148, p=0x97ad128) at
#5  0x0081f903 in deliver (p=0x97ad128, i=0x96a1f48) at deliver.c:483
#6  0x0081e12f in xdb_deliver (i=0x96a1f48, xc=0x971a530) at xdb.c:113
#7  0x0081e4e4 in xdb_get (xc=0x96a21e8, owner=0x96f7d88, ns=0x9a3359
"jabber:iq:auth") at xdb.c:218
#8  0x0098d777 in js_user (si=0x96a2190, id=0x96f7ca8, ht=0x96f9658) at
#9  0x00989a66 in _js_authreg_register (p=0x96f7b80) at authreg.c:123
#10 0x0098a73d in js_authreg (arg=0x96f7b80) at authreg.c:157
#11 0x0081ddc4 in mtq_main (arg=0x96f9190) at mtq.c:153
#12 0x0064d279 in pth_spawn_trampoline ()
from /usr/local/lib/libpth.so.20
#13 0x00148564 in makecontext () from /lib/libc.so.6
#14 0x00000000 in ?? ()

Is this enough debugging info, or should i run gdb with some flags?
Those hex values doesent make much sense to me, but it says something
about that libpth.so.20 again.

Well thank you again, you made my day alot better :)


> The relevant utilities here might be "ldconfig" (which recreates the 
> locations the dynamic linker searches for libraries from the 
> /etc/ld.so.conf file) and "ldd <executable to check>" which can be used 
> to check if the system finds all requires libraries and where they are 
> loaded from.
> Matthias
> add /usr/local/lib/ to /etc/ld.so.conf, and re-run ldconfig.
> (ldconfig 'compiles' ld.so.conf into ld.so.cache - which is used to
> resolve library references)
> -- 
> - Norman Rasmussen
>  - Email: norman at rasmussen.co.za
>  - Home page: http://norman.rasmussen.co.za/

More information about the JDev mailing list