[jdev] Re: Re: [jadmin] Problem building jabber-1.4.1

Matthias Wimmer m at tthias.eu
Wed Mar 14 16:38:25 CDT 2007

Hi Lars!

Lars Sommer schrieb:
> 0x00000001 in ?? ()
> (gdb) bt
> #0  0x00000001 in ?? ()
> #1  0x6fffffff in ?? ()
> #2  0x00000098 in ?? ()
> #3  0x00cc5f18 in xdb_file_phandler (i=0x96a5148, p=0x97ad128,
> arg=0x96a86e0) at xdb_file.c:291
> [...]
> Is this enough debugging info, or should i run gdb with some flags?
> Those hex values doesent make much sense to me, but it says something
> about that libpth.so.20 again.

this time it is no problem in libpth ... the backtrace shows what the 
executable just did when it crashed ... the names (e.g. 
"xdb_file_phandler") there refer to the functions that have called each 
other. Every function is called by the function below it. Therefore the 
last known function call before your server crashed is 
xdb_file_phandler() which is defined in xdb_file.c. There at line 291 
your computer tried to call something else that crashed ...

Which version of jabberd are you exactly using? (It can't be jabberd 
1.4.1 as we have in the subject.) So I can check the right version of 
this file to see where your problem exists. But I'd expect that there is 
some problem to access the file spool of your server. Check that 
directory you have configured in your jabber.xml configuration file 
using the <spool/> element does exist and is read- and writeable by the 
user that is running the jabber server.


More information about the JDev mailing list