[Standards] oauth signature

Seth Fitzsimmons seth at mojodna.net
Sun Feb 15 20:57:53 UTC 2009


> Thanks, I was getting the same signature string with my python code,
> now I know it's correct ;)

Yay!

> I gave a try to the ruby gem too (installed switchboard, fire-hydrant
> and oauth with "sudo gem install mojodna-oauth -s
> http://gems.github.com"), but while switchboard works fine I can't run
> the oauth gem, since I get
>
> /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require': no such file to load -- net/https (LoadError)

You need to install ruby-openssl to get Net::HTTPS.  You're on Debian
/ Ubuntu, right?

> (installed also other gems that were missing, but I can't figure out
> what is missing now, since I really don't know ruby)

What other gems were missing?  I.e., are they dependencies that aren't
listed properly?

>> Note: You may want to use bare JIDs in your URI.
>
> Is fireagle using bare JIDs? Or should the xep be fixed?

Fire Eagle is using bare JIDs (for now; I need to fix this).  The XEP
says that full JIDs can be used.  I think that's right.

seth



More information about the Standards mailing list