[JDEV] server configuration(?) problems

Leonard Guy leonard.guy at frogdesign.com
Fri Apr 28 17:06:34 CDT 2000


Hi,

I've installed Jabber server v.0.9 on a Red Hat 6.1 box and am having
problems getting it to behave properly.

I can connect to it fine and initialize a stream, but any requests to it
return a 406 (Not Acceptable) error.

I'm not sure I have it configured properly - attached is my jserver.xml
file.

I'd be very grateful for any help anyone can offer.

Thanks,
 -Leonard.

A session transcript follows:

sent:
<stream:stream to="170.1.36.175" from="170.1.36.150" xmlns="jabber:client"
xmlns:stream="http://etherx.jabber.org/streams">


rec:
<?xml version='1.0'?><stream:stream
xmlns:stream='http://etherx.jabber.org/streams' id='3909FD60'
xmlns='jabber:client' from='170.1.36.175'>


sent:
<iq type='get' id='uniquevalue' to='170.1.36.175' from='170.1.36.150'>
  <query xmlns='jabber:iq:register'/>
</iq>


rec:
<iq type='error' id='uniquevalue' to='170.1.36.150' from='170.1.36.175'>
  <query xmlns='jabber:iq:register'/>
  <error code='406'>Not Acceptable</error>
</iq>


sent:
<iq type="get" id="uniquevalue" to="170.1.36.175"><query
xmlns="jabber:iq:agents"/></iq>


rec:
<iq type='error' id='uniquevalue' to='170.1.36.175' from='170.1.36.175'>
  <query xmlns='jabber:iq:agents'/>
  <error code='406'>Not Acceptable</error>
</iq>


sent:
</stream:stream>


--DISCONNECTED--
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jserver.xml
Type: text/xml
Size: 9464 bytes
Desc: not available
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20000428/d4b27e98/attachment-0002.bin>


More information about the JDev mailing list