[JDEV] Trouble with local JUD

Constantin Nickonov Nickonov at jabber.com
Wed Apr 4 09:03:59 CDT 2001

Make sure that "jud.vkhdli08.hda.hydro.com" is resolvable, i.e., add it to
the 'hosts' file on the machine on which the Jabber server runs.

Constantin Nickonov

> -----Original Message-----
> From: Ørjan Sandland [mailto:orjan at sandland.ws]
> Sent: Wednesday, April 04, 2001 7:23 AM
> To: jdev at jabber.org
> Subject: [JDEV] Trouble with local JUD
> Hi again folks.
> The "feature" related to WinJab is now ok after switching off 
> the option in
> the client. Thanks for the tip.
> I still have some other problems though, which I think is 
> related to JUD
> somehow.
> Since I'm behind a corporate firewall, I can't make use of 
> the JUD on the
> Internet, so I have tried to install a local instance of it.
> I just did a clean install of jabber, placing the jud 
> directory inside the
> jabber directory.
> Jabber compiles cleanly, but the jud compile gives some 
> warnings like this:
> In file included from jud.c:31:
> jud.h:33:17: warning: "VERSION" redefined
> ../jabberd/jabberd.h:36:1: warning: this is the location of 
> the previous
> definition
> It's been a while since I did any C, so I can't remember what 
> it really
> says. If I recall correctly though, it's not critical.
> I just thought I'd mention it - as it's the only error I've 
> seen besides the
> next (and probably more relevant) one.
> I configured jabber.xml with JUD exactly as the Server Howto 
> 1.4 on the
> docs.jabber.org website.
> The only localization I did, was to change the jud.localhost 
> reference and
> swap it with my local FQDN for the jabber server machine.
> I was a bit puzzled why it was called "jud.localhost" though? 
> I'd assume it
> would only be named localhost?
> I actually tried to use the "jud" in front of the FQDN, making it
> jud.vkhdli08.hda.hydro.com, just to see if that would do some 
> magic, but
> then it gave me different errors (trouble resolving hostname) 
> so I removed
> that.
> I turned on XML debug output in the WinJab client, and when I 
> try to search
> for a contact in the roster menu, this is what happens.
> 1. I select "Jabber User Directory" from the "search via" 
> drop-down box
> 2. I get an incoming message with sender "ERROR", subject 
> "Server Error!"
> and body "Not Found".
> 3. XML debug output is as follows:
> SENT: <iq type="get" id="wjSFields_wj_10" 
> to="vkhdli08.hda.hydro.com"><query
> xmlns="jabber:iq:search"></query></iq>
> RECV: <iq type='error' id='wjSFields_wj_10'
> to='BC_Orjan_Sandland at vkhdli08.hda.hydro.com/BC_Orjan_Sandland_85'
> from='vkhdli08.hda.hydro.com'><query xmlns='jabber:iq:search'/><error
> code='404'>Not Found</error></iq>
> I would like to add, that the search window does not look all 
> normal, as I
> don't get any search criterias for firstname, lastname and 
> similar. Also,
> the "85" on the end of my selected nickname was appended at my first
> registration (on the first installation of jabber). This is my second
> install of jabber....
> Sorry for being so verbose here. I realise that this could be a client
> thing... something conceptual that I didn't understand yet, 
> but it looks
> more like a server problem from my side of it.
> Any suggestions on how to proceed from here is more than 
> welcome, and I hope
> I didn't bore you too much.
> Best regards,
> Ørjan Sandland
> Senior Consultant
> Net Technology AS
> _______________________________________________
> jdev mailing list
> jdev at jabber.org
> http://mailman.jabber.org/listinfo/jdev

More information about the JDev mailing list