[JDEV] Trouble with local JUD

Ørjan Sandland orjan at sandland.ws
Thu Apr 5 02:32:17 CDT 2001

> You will need to have the service called something different than the
> name so traffic can be routed correctly - probably
> This should be set both in the service section for jud, and the agents
> within the jsm 'sessions' configuration (the former telling the server how
> should contact users-agent, the latter telling clients that the jud exists
> where). There may be a requirement that jud.vkhdli08.hda.hydro.com be
> resolvable, if the users-agent uses a socket for the connection - in that
> I'd recommend tossing that in the /etc/hosts file. Clients will speak to
> jud.vkhdli08.hda.hydro.com through the server, so they won't need to know
> IP themselves.

Hi David,

I've been ripping my hair out the last 24 hours... this is still not
I'm sorry to bother you all with these problems, but I would very much like
to get this server up and running.
I'll try to breakdown the details a bit regarding what I've tried.

This is the config that I think should work, but it doesn't (just extracts
of the crucial parts)

file - jabber.xml
<service type="jud" jid="jud.vkhdli08.hda.hydro.com" name="Jabber User
<service id="jud"> <host>jud.vkhdli08.hda.hydro.com</host>
<jud xmlns="jabber:config:jud">
<FN>User Directory on localhost</FN>
<DESC>This service provides a simple user directory service.</DESC>

file - /etc/hosts                    localhost.localdomain localhost
x.x.x.x (ip removed)    vkhdli08.hda.hydro.com

The output I get:

XML debug:
SENT: <iq type="get" id="wjSFields_wj_13"
RECV: <iq type='error' id='wjSFields_wj_13'
to='bark at vkhdli08.hda.hydro.com/bark_650'
from='jud.vkhdli08.hda.hydro.com'><query xmlns='jabber:iq:search'/><error
code='502'>Server Connect Failed</error></iq>

Console log:
20010405T09:14:54: [alert] (jud.vkhdli08.hda.hydro.com): hostname maps back
to ourselves!
20010405T09:14:54: [notice] (jud.vkhdli08.hda.hydro.com): failed to
establish connection
20010405T09:14:54: [notice] (jud.vkhdli08.hda.hydro.com): bouncing a packet
to jud.vkhdli08.hda.hydro.com from bark at vkhdli08.hda.hydro.com/bark_650:
Server Connect Failed

I can note that this machine is a part of a corporate network, with NIS,
DNS, NFS and similar services set up.

Let me try to refresh on some issues so I know I didn't do anything wrong.

1. Services need a separate DNS name than the server itself. Ok.
Q. Why does the console log issue a warning that we're mapping back to
Obviously, the configuration I've set up with the /etc/hosts file results in
jud.vkhdli08.hda.hydro.com maps back to the server, but it still fails to
establish the connection.
How can I be sure that the jud.so file is working allright? After all, I got
some warnings about redefined header when compiling it.

2. Clients speak to the JUD through the server, so only the server needs to
know the jud.vkhdli08...etc alias - hence put it in /etc/hosts
I've tried these combinations in the /etc/hosts file (not at the same time
of course :-).
The x.x.x.x is just a replacement for the hosts ip-address.    jud.vkhdli08.hda.hydro.com
x.x.x.x         jud.vkhdli08.hda.hydro.com    jud.vkhdli08
x.x.x.x         jud.vkhdli08    jud.localhost
x.x.x.x         jud.vkhdli08

Finally, I can mention that I'm quite certain that the "service type"
definition is read by the client, because it changes when I change the text
"Jabber User Directory" to something else.

Again - sorry to bother you with all of this.. I'm afraid that I've made a
little silly error, a typo or something - but I can't find anything.
I have installed a fresh copy of jabber/jud three times now, that should
rule out that there are some typo in my config file or elsewhere.

Thanks for your patience.

Best regards,
Ørjan Sandland
Senior Consultant
Net Technology AS

More information about the JDev mailing list