[JDEV] AIX compilation of jabber server.

Matt Diez matt at vedalabs.com
Thu Feb 1 10:38:16 CST 2001


Have you been successful will compiling 1.4pre1?

This is my process, and I'm quite at a standstill.

Here's the status
1) I added all of the compile time flags (specified by David Clissord on
JDEV) to configure
    AIX)
        CFLAGS="$CFLAGS -DMAXDNAME=1025"
        MCFLAGS="$MCFLAGS -Wl,-G"
        LIBS="$LIBS -lxode -ljabber"
        XLDFLAGS="$XLDFLAGS -Wl,-brtl -Wl,-bexpall";;

2) I ran configure

3) I added the following
#ifdef _AIX
#include <time.h>
#endif
to jsm/modules/mod_time.c and jabberd/lib/jutil.c

4) I ran make. It compiled.

5) I ran jabberd, and got the following.
Loading ./pthsock/pthsock_client.so failed: ''

Invalid Configuration in instance 'c2s':
    <load>
      <pthsock_client>./pthsock/pthsock_client.so</pthsock_client>
    </load>
Matthew Diez

-----Original Message-----
From: David Clissold [mailto:cliss at austin.ibm.com]
Sent: Tuesday, January 30, 2001 12:24 PM
To: jdev at jabber.org
Subject: Re:[JDEV] AIX compilation of jabber server.


I was able to build the server (1.2) using gcc on AIX 4.3.3, by
using the '-G' linker flag for the shared objects (to allow
symbols to be left unresolved until needed by the runtime linker).
Then the main executable, jabberd, needs "-brtl -bexpall" to use
runtime linking and export its symbols to these other objects.

If you are using gcc, you can add this to the configure file
where it has a case statement for different OS's:

    AIX)
        CFLAGS="$CFLAGS -DMAXDNAME=1025"
        MCFLAGS="$MCFLAGS -Wl,-G"
        XLDFLAGS="$XLDFLAGS -Wl,-brtl -Wl,-bexpall";;

Then rerun configure, and remake; it should build to completion.


>I am trying to compile the jabber server under AIX 4.3.3.
>....

David Clissold
cliss at austin.ibm.com

_______________________________________________
jdev mailing list
jdev at jabber.org
http://mailman.jabber.org/listinfo/jdev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20010201/55076949/attachment-0002.htm>


More information about the JDev mailing list