[JDEV] Weird: email getting deleted from Jabber vCard

temas temas at box5.net
Mon Sep 17 18:40:52 CDT 2001


On Mon, 2001-09-17 at 17:11, Jens Alfke wrote:
> I've just found that the email address gets lost when I retrieve a 
> Jabber vCard. On one of my machines I send the following to set the card:
> 
> <iq type="set" id="00000002" to="snej at myserver.com">
> <vCard xmlns="vcard-temp" version="3.0" prodid="-//HandGen//NONSGML vGen 
> v1.0//EN">
> <FN>sneJ Alfke</FN>
> <N>
> <GIVEN>sneJ</GIVEN>
> <FAMILY>Alfke</FAMILY>
> </N>
> <EMAIL>
> <INTERNET/>
> <PREF/>
> jens at mac.com</EMAIL>
> </vCard>
> </iq>
> 
> On the other machine (logged in as a different account) when I retrieve 
> the vCard I get the following:
> 
> <iq type='result' id='00000007' to='jens at myserver.com/Work' 
> from='snej at myserver.com'>
> <vCard xmlns='vcard-temp' version='3.0' prodid='-//HandGen//NONSGML vGen 
> v1.0//EN'>
> <FN>sneJ Alfke</FN>
> <N>
> <GIVEN>sneJ</GIVEN>
> <FAMILY>Alfke</FAMILY>
> </N>
> <EMAIL>
> <INTERNET/>
> <PREF/>
> </EMAIL>
> </vCard></iq>
> 
> You'll note that the vCard content is identical except that the email 
> address itself is missing. These are exact transcripts I just pasted in 
> from my client's XML log, so it definitely looks like the server's 
> fault. Why would this be happening? Anyone else seen this?
> 
> --Jens
> 
> _______________________________________________
> jdev mailing list
> jdev at jabber.org
> http://mailman.jabber.org/listinfo/jdev

That's super weird, and I would love to hear if anyone else has seen
anything like this.

--temas


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20010917/14b7d6d8/attachment-0002.pgp>


More information about the JDev mailing list