[jdev] Jabberd2.0s3: Anyone tried to do a static compile?

Patricia Swarbrick patricia.swarbrick at ideaca.com
Tue Aug 3 15:22:40 CDT 2004

I know this is a repost on the jdev lists, but I don't know if anyone noticed it the first time around.

I've been attempting to do a static compile of Jabberd on a Solaris box with BerkeleyDB.  However, here's what I see when I run the configure:

checking for netinet/in.h... yes
checking resolv.h usability... no
checking resolv.h presence... yes
configure: WARNING: resolv.h: present but cannot be compiled
configure: WARNING: resolv.h:     check for missing prerequisite headers?
configure: WARNING: resolv.h: see the Autoconf documentation
configure: WARNING: resolv.h:     section "Present But Cannot Be Compiled"
configure: WARNING: resolv.h: proceeding with the preprocessor's result
configure: WARNING: resolv.h: in the future, the compiler will take precedence
configure: WARNING:     ## ---------------------------------- ##
configure: WARNING:     ## Report this to the jabberd lists.  ##
configure: WARNING:     ## ---------------------------------- ##
checking for resolv.h... yes
checking signal.h usability... yes

Now I'm not exactly sure what's going on here, but the configure completes successfully.  However, this is what happens when I try to run 'make':

Making all in scod
make[2]: Entering directory `/export/home/sysadmn4/jupgrade/jabberd-2.0s3/scod'
source='mech_anonymous.c' object='mech_anonymous.lo' libtool=yes \
depfile='.deps/mech_anonymous.Plo' tmpdepfile='.deps/mech_anonymous.TPlo' \
depmode=gcc3 /bin/bash ../depcomp \
/bin/bash ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/local/BerkeleyDB/include -I/usr/local/libidn/include -I/usr/local/BerkeleyDB/include -I/usr/local/BerkeleyDB/include/   -g -O2 -c -o mech_anonymous.lo `test -f 'mech_anonymous.c' || echo './'`mech_anonymous.c
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/BerkeleyDB/include -I/usr/local/libidn/include -I/usr/local/BerkeleyDB/include -I/usr/local/BerkeleyDB/include/ -g -O2 -c mech_anonymous.c -MT mech_anonymous.lo -MD -MP -MF .deps/mech_anonymous.TPlo  -fPIC -DPIC -o .libs/mech_anonymous.o
In file included from scod.h:23,
                 from mech_anonymous.c:22:
../util/util.h:546: field `ip' has incomplete type
../util/util.h:548: confused by earlier errors, bailing out
make[2]: *** [mech_anonymous.lo] Error 1
make[2]: Leaving directory `/export/home/sysadmn4/jupgrade/jabberd-2.0s3/scod'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/sysadmn4/jupgrade/jabberd-2.0s3'
make: *** [all] Error 2

Now I've looked through the code and I've traced it down to the sockaddr_storage function. I'm not sure what's going on with this, maybe there's another function called sockaddr_storage that's being brought in but that doesn't work properly. I'll have to look in to it a little more in depth later on. I hope there's something that can be done about this, since I'd like to upgrade my Jabber server to 2.0s3 sometime in the near future. 


More information about the JDev mailing list