[jdev] jabberd xml parser Bug?

Alexey Nezhdanov snake at penza-gsm.ru
Sat Feb 14 23:00:24 CST 2004


Tryed this xml chunk on my jabberd1.4.3. Server worked it fine w/o any 
delays.

--
Alexey Nezhdanov

>Hello,
>
>while playing around with XData forms i stumbled in following problem:
>The parser in jabberd seems to have some problems with the XML below. Most
>time when i send this XML it doesnt reach the receiver immediately. I assume
>that its hanging in the queue of the parser an the parser assumes that this
>XML-Element is not complete (depth > 1). After i send another packet to the
>receiver, eg. a presence packet, he gets the both packages at the same time
>then. I treid that on different jabberd 1.42 and 1.43 server. Also wpJabber
>has the same problem.
>
>Alex
>
>XML:
><message to='foo at jabber.org'>
><subject>Vote #134</subject>
><body>Please take the time to vote on this matter. Thanks!</body>
><thread>vote-thread-reatmon-134</thread>
><x xmlns='jabber:x:data' type='form'>
><title>Vote #134</title>
><instructions>This is the vote to pick a new mascot. Thanks for
>your time!</instructions>
><field var='mascot' type='list-single'>
><required/>
><option label='Light Bulb'><value>light_bulb</value></option>
><option label='Penguin'><value>penguin</value></option>
><option label='Moose'><value>moose</value></option>
><option label='Triangle Man'><value>triangle_man</value></option>
><option label='Other'><value>other</value></option>
></field>
><field var='other_mascot' type='text-single'/>
><field var='color' type='list-single'>
><required/>
><option label='Red'><value>red</value></option>
><option label='Blue'><value>blue</value></option>
><option label='Green'><value>green</value></option>
><option label='Black/White'><value>black_white</value></option>
></field>
></x>
></message>
>
>_______________________________________________
>jdev mailing list
>jdev at jabber.org
>https://jabberstudio.org/mailman/listinfo/jdev
>
>
>
>
>  
>







More information about the JDev mailing list