[jdev] Re: JabberD 1.4.3 and MU-Conference 0.6.0 for Win32/Cygwin

Frank Seesink frank at mail.wvnet.edu
Fri Feb 27 20:58:01 CST 2004


Actually, I believe Alexander was correct in doing a reply to, as it 
appears he is writing "in reply to" the initial post by James White 
regarding the bundled Jabberd 1.4.3/MU-C Cygwin build James put together.



Have you been able to get s2s working for yourself, and if so, what 
version of Cygwin's DLL and so forth are you using?



Same question regarding version of Cygwin DLL.

The issue you are experiencing is one I've been having myself.  James' 
reference to 'Frank' would be me, and your s2s issue is one which I 
started encountering in the past month.  I have had jabberd v1.4.3 
running with JUD v0.5 and MU-Confernence v0.6 for some time now under 
Cygwin.  In fact, jabberd & JUD since last June/July, and Jabberd v1.4.3 
since it was released.  And from that time until sometime near the end 
of January 2004 I had absolutely NO trouble doing s2s and connecting to 
multiuser chats on Jabber.org, etc.  Basically, Jabberd ran under Cygwin 
like it does under Linux/etc.

However, something changed around the end of January/beginning of 
February 2004, and it wasn't on my end.  Suddenly I could no longer do 
s2s to Jabber.org nor Tipic.com.  I could not browse conference rooms, 
and attempts to connect directly failed as well.

I posted on jadmin asking if there had been any changes.  This was also 
about the time that Peter Saint-Andre & co. moved the mailing lists (I 
got bitten by that one I'm afraid).  Peter said the move really had 
nothing to do with the Jabber.org jabber server, and in reply to my 
question asking if any DNS changes had been made, Peter said none had 
been made in some time.  So I figured the issue was mine.

Running Jabberd under Cygwin is a cludge...my cludge, basically, as I'm 
the one who hacked on it until 1.4.3 would build cleanly under Cygwin 
like elsewhere.  It's still unique in the whole dnsrv module with its 
separate executable.  (This was in 1.4.2 and I can't take credit for it. 
  The real work was done by others.  I simply tweaked.)  So I've learned 
not to bitch too loudly, as I figure the issue maybe is mine and mine alone.

Possibly some update in Cygwin screwed things up.  I re-run Cygwin's 
setup.exe from time to time in order to get the latest libraries, etc. 
I believe I was using the 1.5.5 version of the cygwin1.dll with whatever 
versions of libraries were out then.  1.5.7 was released on 31Jan2004, 
which is right in that same timeframe.  So not sure if we're looking at 
a Cygwin snafu vs. a jabberd build snafu.

Anyway, just wanted to let you know that you're not alone, Alexander. 
Hopefully we can track this one down.  I'd like to get back to where I 
was back in January.  This is also, by the way, one of the reasons 
(along with limited free time) why I haven't gotten around to building 
anything like James' zip file.  (Thanks, James, for doing that.)

I still hope to build a proper Windows installer if I can get the last 
of the kinks worked out.  'til then, anyone else using James' Cygwin 
build or their own please post here if you're having s2s issues, and if 
not, please provide the details of the version of the Cygwin DLL, etc., 
that you're using.  Any feedback could help.

Alexey Nezhdanov wrote:
> В сообщении от 25 Февраль 2004 14:59 Alexander Gnauck написал(a):
> Please start new thread. You're posting "in reply to". This is improper.
>>s2s doesnt work for me. I think smth goes wrong with dnsrv. It returns
>>always all packages with error 502 unable to resolve hostname. s2s port
>>is routed. It accepts incoming connections but cant resolve domains for
>>dialback. Some ideas whats going wrong? I tried to connect to lots of
>>different jabber servers without access.
>>jabber at rationalpath.com wrote:
>>>With the following grain of salt (Windows developer, almost no
>>>knowledge of Cygwin/JabberD/anything without a menu and intellisense)
>>>and with a big thanks to Frank for posting all the
>>>notes/patches/howto's, etc, I present:
>>>JabberD 1.4.3 & MU-Conference 0.6.0 Compiled for Win32/Cygwin
>>>James White
>>jdev mailing list
>>jdev at jabber.org

More information about the JDev mailing list