[jdev] Odd problems for a newbie

Tim Fulcher - Clickatell tim.fulcher at clickatell.com
Thu Jun 2 08:38:35 CDT 2005

Hi all
I have had two problems installing and setting up JabberD, firstly after
installing 2.0s8 i got a recurrent c2s shutdown/broken pipe as a result
of an authentication problem with mysql. Checks revealed that nothing
seemed to be amiss. Eventually out of desperation we tried the c2s
binary from a previous installation of 2.0s3 and bingo! It worked. Any
ideas here.
Next problem is more pressing. Having succeeded in getting JabberD up
and going I tried to open a client (Exodus) to that JabberD server and
was met by (from the Exodus debug):
Looking up SRV: _xmpp-client._tcp.dev.clickatell.com

Got A: 5222

SENT: <stream:stream to="dev.clickatell.com" xmlns="jabber:client"
xmlns:stream="http://etherx.jabber.org/streams" version="1.0" >

RECV: <?xml version='1.0'?><stream:stream
xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client'
from='dev.clickatell.com' version='1.0'

RECV: <stream:error
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>service requested for
unknown domain</text></stream:error></stream:stream>

Googling it seems that the localhost in the c2s.xml file was incorrect
which it was, so I corrected it but the same problem occured. Again, any

Kind Regards

Tim Fulcher

More information about the JDev mailing list