[jdev] Re: Odd problems for a newbie

Stephen Marquard scm at marquard.net
Thu Jun 2 10:59:07 CDT 2005

Tim Fulcher - Clickatell wrote:
> Hi all
> I have had two problems installing and setting up JabberD, firstly after
> installing 2.0s8 i got a recurrent c2s shutdown/broken pipe as a result
> of an authentication problem with mysql. Checks revealed that nothing
> seemed to be amiss. Eventually out of desperation we tried the c2s
> binary from a previous installation of 2.0s3 and bingo! It worked. Any
> ideas here.

This really belongs on the jadmin or jabberd list, but anyway.

If you provide more details about the mysql problem, maybe someone can 
help. 2.0s3 is rather old.

> Next problem is more pressing. Having succeeded in getting JabberD up
> and going I tried to open a client (Exodus) to that JabberD server and
> was met by (from the Exodus debug):
> Looking up SRV: _xmpp-client._tcp.dev.clickatell.com
> Got A: 5222
> SENT: <stream:stream to="dev.clickatell.com" xmlns="jabber:client"
> xmlns:stream="http://etherx.jabber.org/streams" version="1.0" >
> RECV: <?xml version='1.0'?><stream:stream
> xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client'
> from='dev.clickatell.com' version='1.0'
> id='onqnhdbn9jqx93tr29tn7hm1vbi5t3mird58qhv0'>
> RECV: <stream:error
> xmlns:stream='http://etherx.jabber.org/streams'><host-unknown
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>service requested for
> unknown domain</text></stream:error></stream:stream>
> Googling it seems that the localhost in the c2s.xml file was incorrect
> which it was, so I corrected it but the same problem occured. Again, any
> ideas.

The domain specified in c2s.xml and/or sm.xml is wrong (i.e. does not 
match "dev.clickatell.com"). In c2s.xml, it's specified as <id> in the 
<local> section. In sm.xml, the domain is specified in <id> in the <sm> 


More information about the JDev mailing list