[jdev] XMPP client/server issues with Flash-based client

M. David Peterson xmlhacker at gmail.com
Sun Mar 4 16:34:12 CST 2007


Hey All,

Peter Fisk (Cc'd) has developed direct support for XMPP into Vista
Smalltalk, a .NET and now Flash-based implementation of Smalltalk and Lisp.
It seems he's run into some problems, however, with getting XMPP to work in
the Flash-based version (see:
http://vistascript.net/vistascript/flex/vst.swf for a working demo and visit
http://vistasmalltalk.wordpress.com/ for a running list of entries that
provide various demo's to help get you started)

In follow-up to a question I posed to Peter in a recent blog entry,

@
http://vistasmalltalk.wordpress.com/2007/02/22/wpfe-10-wont-support-clr/#comment-3676

David,
> On opening a socket connection to any Jabber server, I can catch the
> "connection established" event after which it seems to hang. There is no
> problem connecting from Flash to http servers and I can connect to Jabber
> using Exodus with no problem. I added a "crossdomain.xml" file to the same
> directory as the *.swf file:
>
> Any thoughts?


I personally don't have enough experience with Flash to be able to know the
answer (or at least the possible answer) to the problem.  Am digging around
a bit to see what I might be able to come up with (I doubt much I need to
express to this list how cool it would be to have this capability built into
a Smalltalk/Lisp interpreter for Flash! ;-)), but it seemed worth posting
this to the dev-list to see if anyone else out there might be able to lead
and guide me, and ultimately, Peter, to the solution.

Thanks in advance for any and all help/advice!

-- 
/M:D

M. David Peterson
http://mdavid.name | http://www.oreillynet.com/pub/au/2354 |
http://dev.aol.com/blog/3155
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20070304/f91b30d2/attachment-0002.htm>


More information about the JDev mailing list