[jdev] Problem of the EchoComponent sample code

Xiang (Gavin) Ye gavin.ye at gmail.com
Fri Feb 5 16:33:45 CST 2010


Hi Norman,

I see.
Thanks a lot for your reply!

== Gavin

On Fri, Feb 5, 2010 at 1:10 PM, Norman Rasmussen <norman at rasmussen.co.za>wrote:

> Gavin: this mailing list can't help much with anything Jabber Inc. XCP
> related.  I suggest you contact Jabber Inc. directly for support.
>
> On Thu, Feb 4, 2010 at 10:55 PM, Xiang (Gavin) Ye <gavin.ye at gmail.com>wrote:
>
>> Hi,
>>
>> It's the first time I work on jabber.
>> I am trying to write a Jabber Event Broker which can block user action or
>> filter the message.
>>
>> I compiled EchoComponent sample code and put it on my Jabber Server (It's
>> a Jabber XCP 5.4 from Jabber Inc). But it started and then exit.
>> I can see an error message: "Pipe creation failed. Exiting the
>> Application!".
>>
>> After that, I compiled the Java sample code. It also failed, but with more
>> information:
>>     2/4/10 12:27:40 AM [DEBUG]: ComponentProxy::onInitialize
>>     2/4/10 12:27:40 AM [DEBUG]: Component::onInitialize
>>     2/4/10 12:27:40 AM [INFO]: Connecting to the router @ /10.187.4.155:7
>> ,400
>>     2/4/10 12:27:40 AM [INFO]: Connected to the router @ /10.187.4.155:7
>> ,400
>>     2/4/10 12:27:40 AM [DEBUG]: XMLStream writing: <stream:stream
>> xmlns='jabber:component:accept' xmlns:stream='
>> http://etherx.jabber.org/streams' to='eventbroker.jabber'>
>>     2/4/10 12:27:40 AM [DEBUG]: ComponentStream.onStreamOpen
>>     2/4/10 12:27:40 AM [DEBUG]: XMLStream writing:
>> <handshake>a187f586667d8a82ebdb69a7407c952c4a857692</handshake>
>>     2/4/10 12:27:40 AM [ERROR]: Component authentication with router
>> failed.
>>     2/4/10 12:27:40 AM [DEBUG]: ComponentStream.onStreamError: Software
>> caused connection abort: recv failed
>>     2/4/10 12:27:40 AM [DEBUG]: EventBroker exited with SUCCESS
>>
>> It seems it needs authentication with router.
>> Here is my question:
>>   1. Where can I configure the Component Authentication?
>>   2. Is there any extra steps I need to do except configure the JSM and
>> OpenPort?
>>
>> Thanks!
>>
>> == Gavin
>>
>> _______________________________________________
>> JDev mailing list
>> Forum: http://www.jabberforum.org/forumdisplay.php?f=20
>> Info: http://mail.jabber.org/mailman/listinfo/jdev
>> Unsubscribe: JDev-unsubscribe at jabber.org
>> _______________________________________________
>>
>>
>
>
> --
> - Norman Rasmussen
> - Email: norman at rasmussen.co.za
> - Home page: http://norman.rasmussen.co.za/
>
> _______________________________________________
> JDev mailing list
> Forum: http://www.jabberforum.org/forumdisplay.php?f=20
> Info: http://mail.jabber.org/mailman/listinfo/jdev
> Unsubscribe: JDev-unsubscribe at jabber.org
> _______________________________________________
>
>


-- 
==============================
How to redeem ?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20100205/a64c95f8/attachment.htm>


More information about the JDev mailing list