[jdev] Sending nickname in subscription presence to gtalk users doesn't work

Daniel Dormont dan at greywallsoftware.com
Tue Apr 23 23:00:30 UTC 2013


I've run into the same problem. I can't reproduce it this second because
I'm getting a remote-server-not-found error for any outgoing Google stuff
at the moment, but looking at my roster in my own Gmail account I see the
bare JID, not the nick, of the account that sent that subscription to me.

dan

On Tue, Apr 23, 2013 at 3:09 AM, Vineet Naik <naikvin at gmail.com> wrote:

> Hello,
>
> I am working on an xmpp component (with ejabberd server) that
> needs to send subscription requests to gtalk users. In the
> presence stanza I include a nickname as per the xep-0172 User
> nickname protocol [1]. But the nickname doesn't appear when the
> gtalk user receives the invitations (in the gmail web client) and
> also when they are accepted. Instead it shows the node part of
> the jid.
>
> I understand that this is an extension so google may choose not
> to respect the nickname. But I have myself subscribed to a few
> bots for which the nickname is displayed correctly.
>
> Does any one know how to tell google to use the nickname instead
> of the node in the invitations as well as in roster?
>
> [1]: http://xmpp.org/extensions/xep-0172.html#subscription
>
> Thanks,
> Vineet
>
>
> _______________________________________________
> JDev mailing list
> Info: http://mail.jabber.org/mailman/listinfo/jdev
> Unsubscribe: JDev-unsubscribe at jabber.org
> _______________________________________________
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20130423/542e28a9/attachment.html>


More information about the JDev mailing list