[jdev] XEP-0333 - Chat Markers for MUC's

george b scooterschorschi at gmail.com
Tue Sep 17 19:57:00 UTC 2019


Got it working now.

But interesting, conversations only displays the '... has read up to this
point' label when I use the 'Sending a Message to All Occupants' approach.
In my opinion, the 'Private Message' approach within a MUC should be
sufficient here.

Does someone knows the reason for this?

Best regards
Schorsch


Am Sa., 14. Sept. 2019 um 08:15 Uhr schrieb Georg <
scooterschorschi at gmail.com>:

> Hi
>
> I also implemented xep184. It works fine, but only for delivery receipts.
> It does not work for the 'displayed' status.
>
> I mostley test against conversations client. Shmoose is currently able to
> request the chat-markers and process the answers, also from MUC's. The last
> remaining piece is the answering of chat-markers for the displayed status
> within MUC's.
>
> Best regards
> Schorsch
>
>
>
>
> Am Freitag, 13. September 2019 schrieb Dave Cridland:
> > On Fri, 13 Sep 2019 at 22:08, george b <scooterschorschi at gmail.com>
> wrote:
> >
> > > Thanks for the quick response :-).
> > > I read the xep and it sounds like what I was looking for. I tried it
> but
> > > it doesn't work within the first test. I have to investigate more
> what's
> > > going on there.
> > >
> > >
> > A lot of clients use XEP-0184 instead, and many ignore both entirely from
> > XEP-0045 chatrooms.
> >
> >
> > > Best regards
> > > Schorsch
> > >
> > > Am Fr., 13. Sept. 2019 um 21:02 Uhr schrieb Dave Cridland <
> > > dave at cridland.net>:
> > >
> > >>
> > >>
> > >> On Fri, 13 Sep 2019 at 19:27, george b <scooterschorschi at gmail.com>
> > >> wrote:
> > >>
> > >>> Hi
> > >>>
> > >>> I am struggling with chat markers in MUC's.
> > >>>
> > >>> In 1on1 chat, this works like expected:
> > >>>
> > >>> <message from="aa at jabber-germany.de/shmoose" id="
> > >>> ce3f1534-ef71-4d6f-b699-661342ab4803" to="bb at jabber.de" type="chat">
> > >>>
> > >>> <body>body</body>
> > >>>
> > >>> <markable xmlns="urn:xmpp:chat-markers:0"></markable>
> > >>>
> > >>> </message>
> > >>>
> > >>> <message id="33abcee5-7784-47eb-8841-14ba3e725d30" to="aa@
> > >>> jabber-germany.de" from="bb at jabber.de/shmoose">
> > >>>
> > >>> <displayed xmlns="urn:xmpp:chat-markers:0" id="
> > >>> ce3f1534-ef71-4d6f-b699-661342ab4803"></displayed>
> > >>>
> > >>> </message>
> > >>>
> > >>>
> > >>> But what is the 'to' address to answer the <markable> tag on MUC's?
> The
> > >>> endclient didn't know the real jabber ID of the requesting room
> member. I
> > >>> tried sending the <displayed> tag to the room. Does not work. I
> tried to
> > >>> send the <displayed> tag to the room with the members name as a
> resource.
> > >>> Does not work.
> > >>>
> > >>>
> > >>> Does someone has a hint for me here? The description in the xep 0333
> > >>> does not help here (at least for me).
> > >>>
> > >>>
> > >>>
> > >> There are two options:
> > >>
> > >> * Send the marker to the entire room (XEP-0045§7.4). This means that
> > >> everyone sees when everyone reads the messages, which is a lot of
> > >> information - and a lot of traffic.
> > >> * Send the marker as a PM (XEP-0045§7.5). This means only the sender
> sees
> > >> who has read their own messages - it's still a surprising amount of
> traffic
> > >> though!
> > >>
> > >> Dave.
> > >> _______________________________________________
> > >> JDev mailing list
> > >> Info: https://mail.jabber.org/mailman/listinfo/jdev
> > >> Unsubscribe: JDev-unsubscribe at jabber.org
> > >> _______________________________________________
> > >>
> > > _______________________________________________
> > > JDev mailing list
> > > Info: https://mail.jabber.org/mailman/listinfo/jdev
> > > Unsubscribe: JDev-unsubscribe at jabber.org
> > > _______________________________________________
> > >
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20190917/858b955c/attachment.html>


More information about the JDev mailing list