[jdev] Omemo: confused by devicelist via pep

george b scooterschorschi at gmail.com
Tue Jan 26 19:36:57 UTC 2021


Hello all

I had included omemo in shmoose [1] by using libomemo with axc and
integrated lurch [2] by implementing an adapter to use without libpurple.
So far so good, it is working as expected.

The only thing wich does not work is deploying the devicelist via pep. I
had to ask for devicelist manually to use omemo encryption.

According to omemo xep [3] 5.2: "Devices MUST subscribe to
urn:xmpp:omemo:1:devices via PEP". But pep state [4] 1.2: "because they are
subscribed to your presence, they automatically receive your events". I
would expect, as long as the users are subscribed to the others presence,
they will automatically receive the devicelist nodes and updates? That does
not work for me.

This is the pep node shmoose client sends during add of devicelist entry:

<iq xmlns="jabber:client" id="d0093daf-8c93-4c3c-8382-68d0d1454295" type="
set">

<pubsub xmlns="http://jabber.org/protocol/pubsub">

<publish node="eu.siacs.conversations.axolotl.devicelist">

<item>

<list xmlns="eu.siacs.conversations.axolotl">

<device id="339564329"></device>

</list>

</item>

</publish>

</pubsub>

</iq>

As far as I understood it, this should trigger an automated message stanza
update to all presence-subscribed users. But it doesn't.

Any hints on this issue are appreciated.

Best regards
geobra

[1] https://github.com/geobra/harbour-shmoose
[2] https://github.com/gkdr/lurch/
[3] https://xmpp.org/extensions/xep-0384.html
[4] https://xmpp.org/extensions/xep-0163.html

P.S.
I am aware that this is not the latest omemo version. But this is what the
lurch plugin currently implements.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/jdev/attachments/20210126/f89ea9e8/attachment.html>


More information about the JDev mailing list