[Juser] Error during compile

Justin Kirby justin at openaether.org
Mon Dec 2 12:03:19 CST 2002


The 4.1 dependency is specific to jabberd2.0 which is currently in
'alpha'. If you are setting up a production based server, you should be
using jabberd1.4.x

If you *want* to test the 2.0 code (which would be greatly appreciated)
then the error is usually caused by the software package not being in
the standard locations. There *should* be a --with-db option or some way
of specifying the installed directory of db (if not, thats a bug and
should be reported).

However, the best list to ask this question on is the jadmin list which
you can find at http://www.jabber.org/about/lists.php

Justin

On Thu, 2002-11-28 at 18:09, Nevin Swan wrote:
> Hi,
> 
> I am attempting to install Jabber on a Redhat7.3 box, when i ./configure i get the following error:
> 
> <snip>
> checking for libdb-4.1... no
> configure: error:
> **************************************************
> * libdb-4 not found.  Please install to continue *
> **************************************************
> </snip>
> 
> 
> I assume this refers to the Berkley DB 4.1 that is requested to be installed in the README file, although i thought i had already installed this using this file 'db-4.1.24.tar.gz' which i compiled no problems?
> 
> Can you tell me where i am going wrong?
> 
> Thanks in advance,
> Nevin.
> _______________________________________________
> Juser mailing list
> Juser at jabber.org
> http://jabber.org/cgi-bin/mailman/listinfo/juser






More information about the JUser mailing list