[Juser] Room creation difficulties

Peter Saint-Andre stpeter at jabber.org
Tue Feb 22 17:13:20 CST 2005


Chatrooms are not part of most jabber servers -- you need to run an
additional component. In jabberd2 this is a bit tricky, since normally
you need to run the Jabber Component Runtime in addition to the
mu-conference component. But the JADMIN list is the right place for such
questions.

/psa

On Tue, Feb 22, 2005 at 02:54:23PM -0800, Tom Maddox wrote:
> Hi, everyone,
> 
> I tried submitting this question to the JADMIN list, but I got no response,
> so I'm hoping someone on this list might have an answer.
> 
> I've just set up a Jabber 2 server running on Solaris, and I'm having a
> problem with the chat room functionality.  I can apparently create a room
> just fine, but whenever I try to chat in it or change the subject, an error
> is generated.  When I try to connect to the room from another client, I get
> a response back that the room does not exist, even though the client appears
> to think that it has successfully created it.  Here's what I see in the
> client log when I try to post to the room:
> 
> RECV: <message xmlns='jabber:client' from='testroom at jabberd2.yodlee.com'
> type='error' to='tmaddox at jabberd2.yodlee.com/Exodus' id='jcl_9'><error
> type='cancel' code='404'><item-not-found
> xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error><body>h</body></message
> >
> 
> I tried running the server in debug mode, but I didn't get any useful
> output.  Does anyone have any idea what might be causing this problem?
> 
> TIA,
> 
> Tom
> 
> 
> --
> Tom Maddox, MCSE, SCSA, BOFH
> Yodlee, Inc., Development Systems Administrator
> "Most people who want to hide their source code do so out of embarassment."
> Randal L. Scwartz, as seen on  comp.os.linux.admin
> Jabber:  tmaddox at jabberd2.yodlee.com
> 



More information about the JUser mailing list