[Operators] Gmail federation

Jonas Ådahl jadahl at gmail.com
Thu Feb 23 15:59:30 UTC 2012


On Thu, Feb 23, 2012 at 3:50 PM, Juan Pablo Carlino <jpcarlino at gmail.com> wrote:
> Hello,
>
> during the last three months i've experienced an intermittent problem to
> federate with google.com. Actually this is a common problem if you browse
> the web in search for this issue -there are several old threads reporting
> the same, until some magic happens on Google side and everything goes back
> to the expected behaviour-. But this time, the strange thing is that some of
> the virtual hosts i manage on my ejabberd 2.1 server can federate fine,
> while others don't. Moreover, these domains with problems later can do s2s
> fine with Google, without any change on my side.
> The symptom is always the same: during s2s handshake the outgoing connection
> from my server closes by timeout waiting for a reply from Google on the
> wait_for_validation state. But i don't see why some domains remain
> unaffected while others don't.
> If anybody is experiencing the same issue i would be glad to know about it.
>
> Regards,
>
> Juan Pablo

Hi

We experienced the same issue. We had two domains running on the same
ejabberd node. One could communicate with the Google Talk servers, the
other could not. At the time I dug into the problem and my conclusion
was a buggy Google s2s implementation. In our case, one day it
suddenly started to work. No configuration changes or restarts. I have
yet to hear any comments about this issue from the Google Talks team.


Jonas


More information about the Operators mailing list