[Operators] Gmail federation

Björn Kempén buffi at google.com
Wed Mar 7 13:58:19 UTC 2012


I'm posting an update to this email thread since I was asked to keep
other XMPP operators posted with any updates on the investigations.

I've been in contact with several owners of federated networks, and
performed debugging sessions which hasn't really lead to anything
conclusive.
None of the cases that I've gone through seems to have been related to
the intermittent problem reported here though, and I'm still open to
debugging these issues further.
The people I've been in contact with have either had configuration
issues on one or more of their domains, or experienced problems with
connecting to us in the past but not currently.

Basically, if you have noticed a regression in your services since a
few months ago where you are no longer able to setup a connection to
us, feel free to contact me and I'll look into it.
We'd like to find any regressions in our server-to-server code to
provide a better experience for other federated XMPP networks.
You can also email us at xmpp at google.com , which is an email alias for
several Google engineers working on our XMPP infastructure.

- Björn, Google

On Thu, Feb 23, 2012 at 3:50 PM, Juan Pablo Carlino <jpcarlino at gmail.com> wrote:
> Hello,
>
> during the last three months i've experienced an intermittent problem to
> federate with google.com. Actually this is a common problem if you browse
> the web in search for this issue -there are several old threads reporting
> the same, until some magic happens on Google side and everything goes back
> to the expected behaviour-. But this time, the strange thing is that some of
> the virtual hosts i manage on my ejabberd 2.1 server can federate fine,
> while others don't. Moreover, these domains with problems later can do s2s
> fine with Google, without any change on my side.
> The symptom is always the same: during s2s handshake the outgoing connection
> from my server closes by timeout waiting for a reply from Google on the
> wait_for_validation state. But i don't see why some domains remain
> unaffected while others don't.
> If anybody is experiencing the same issue i would be glad to know about it.
>
> Regards,
>
> Juan Pablo


More information about the Operators mailing list