[Operators] Gmail federation

Björn Kempén buffi at google.com
Fri Jan 11 09:25:39 UTC 2013


Juan Pablo Carlino:
I suspect that our servers notice that your server is unreachable, and
cache this to not attempt to set up a new connection for each outgoing
message addressed to your domain.
It seems strange that this cache would disallow connections for two days
though, so I'll look into it.

Mathias Erti:
We resolved some issues with Federation connections a few months back, but
if you're still experiencing issues, feel free to write up what exactly
you're seeing, and what you're doing to reproduce it.


On Thu, Jan 10, 2013 at 8:15 PM, Mathias Ertl <mati at fsinf.at> wrote:

> Hi Björn,
>
> On 2012-02-27 11:24, Björn Kempén wrote:
> > I will update this email thread when I have any updates.
>
> Sorry for my impatience, but are there any updates? :-)
>
> greetings, Mati
>
> > On Mon, Feb 27, 2012 at 11:20 AM, Peter Viskup <skupko.sk at gmail.com>
> wrote:
> >> On 02/27/2012 11:04 AM, Björn Kempén wrote:
> >>>
> >>> Thanks, I was not aware of this issue, and I'll file an internal bug
> for
> >>> it :)
> >>>
> >>>
> >>> Also, I've sent out private emails in response to some of the people
> >>> offering to help out with the server-to-server debugging.
> >>> Thanks a lot for offering to help us out with debugging this issue.
> >>>
> >>> Currently, our server fails a lot of attempted dialback for "real"
> >>> reasons, such as domains lacking SRV records, which can make it very
> >>> hard to detect regressions in the dialback code.
> >>> I'm hoping to have the issues reported here resolved as soon as
> possible.
> >>>
> >>> Thanks.
> >>> - Björn, Google
> >>>
> >>>
> >>> On Sun, Feb 26, 2012 at 1:35 PM, sergio<mailbox at sergio.spb.ru>  wrote:
> >>>>
> >>>> Hello, Björn.
> >>>>
> >>>>> I am one of the guys at Google responsible for our Google Talk XMPP
> >>>>> Federation implementation. We'd like to debug this issue a bit more
> >>>>> in-depth to figure out what's going on.
> >>>>
> >>>> It's very good! We waited for you.
> >>>>
> >>>> Really I have another problem, but with similar symptoms.
> >>>> The problem is that google (gmail) doesn't work with fallback (lower
> srv
> >>>> recorded) servers. Only with primary.
> >>>> I've already described it here:
> >>>> http://mail.jabber.org/pipermail/operators/2011-April/001138.html
> >>>>
> >>>>> It would be very helpful for us to have a conversation (over chat or
> >>>>> phone) with someone having these connection issues, while having a
> >>>>> short debugging session where a federated domain attempt to connect
> to
> >>>>> us.
> >>>>
> >>>> Yes! My jid is sergio at jabber.ru.net
> >>>>
> >>>> --
> >>>> sergio.
> >>
> >>
> >> Hi Bjoern,
> >> nice to see somebody from Google taking care of this. Anyway - is it
> >> possible for us to check updates about ongoing investigation of this
> issue?
> >> Thank you.
> >>
> >> Best regards,
> >> --
> >> Peter Viskup
>
>
> --
> twitter: @mathiasertl | soup: http://soup.er.tl | xing: Mathias Ertl
> I only read plain-text mail!  I prefer signed/encrypted mail!
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.jabber.org/pipermail/operators/attachments/20130111/ed8fa454/attachment.html>


More information about the Operators mailing list