[Operators] xmpp.net test: Connection failed

Thijs Alkemade thijs at xnyhps.nl
Fri Feb 7 13:36:40 UTC 2014


On 7 feb. 2014, at 14:15, Daniele Ricci <daniele.athome at gmail.com> wrote:

> Ok that's weird. This morning someone (not me) started a test against
> kontalk.net and it worked (result was B).
> I just started the same test a couple of minutes ago, same error:
> Connection failed.
> 
> This is the test that went well:
> https://xmpp.net/result.php?id=16375
> 
> And this is the latest test by me:
> https://xmpp.net/result.php?id=16406
> 
> What am I doing wrong?

Sorry, I read the thread but I completely forgot to update you!

I reran the test manually this morning, but as it happens, the tests I run
manually do not present a client certificate, while the automated tests do (it
matters for s2s and to detect EXTERNAL). It's a self-signed certificate, I'm
not even sure it's valid for the stream 'from'.

Checking manually with openssl s_client, it seems you immediately close
connections that present a client certificate. Maybe that doesn’t work, or do
you reject self-signed certificates?

Regards,
Thijs

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 841 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://mail.jabber.org/pipermail/operators/attachments/20140207/b21522de/attachment.pgp>


More information about the Operators mailing list