[standards-jig] software version

Jacek Konieczny jajcus at bnet.pl
Sun Jul 27 18:49:32 UTC 2003


On Sun, Jul 27, 2003 at 02:20:26PM -0400, Evan Prodromou wrote:
>             <-----------------
>                [disco result]
>             jabber:iq:version
>             jabber:iq:version:2 (or whatever)

And now:
- disco feature list grows and grows
- clients need not only implement current jabber:iq:version,
bug jabber:iq:version and jabber:iq:version:2. If we do the same for 
other protocols clients will have to implement lots of nearly-the-same
protocols. This doesn't look clean to me.

Even XMPP specs say that protocol elements don't have to be valid
against provided schemas and that implementations should not assume they
are valid.

Greets,
        Jacek



More information about the Standards mailing list