[Standards-JIG] JEP 60 - pubsub#error seems to be missing errors

Peter Saint-Andre stpeter at jabber.org
Fri May 20 21:22:22 UTC 2005


On Mon, Apr 25, 2005 at 10:32:26PM -0700, Chris Mullins wrote:
> 
> JEP 60 (section 15.4) defines 5 error conditions in the pubsub#error
> namespace.
> - 'invalid-options'
> - 'node-not-configurable'
> - 'persistence-unavailable'
> - 'not-subscribed'
> - 'subscription-options-unavailable'
> 
> It seems like a huge number of items are missing from this list and
> should be added:
> - 'affiliations-not-retrivable'
> - 'items-not-enumerable'
> - etc
> 
> Pretty much for each feature that's listed in 14.3, it seems like there
> should be a corresponding error in the error namespace. 

Sure, that's probably a good idea.

And here's another idea: name them consistently so that feature-related
errors are of the form "[feature-name]-unsupported", such as:

<collections-unsupported/>
<config-node-unsupported/>
<create-nodes-unsupported/>
<delete-notes-unsupported/>

And so on.

Sound good?

/psa




More information about the Standards mailing list