[Standards] Wording JID, FullJid, baseJID,...
justin-keyword-jabber.093179 at affinix.com
Mon Jun 22 21:49:53 UTC 2009
On Monday 22 June 2009 09:21:35 Ralph Meijer wrote:
> I find it highly confusing to have optional part of a JID before the '@'
> also be called Node. As I don't feel like changing any protocol over
> this, could we possibly change the name of this JID part in 3920bis?
"Node" as the name of a JID component has been in use for at least 5 years, is
defined in our most critical spec possible (XMPP-Core), and is likely
littered all over codebases ("jid.node = foo").
I say we're stuck with using the term in both JID and PubSub contexts. This
is not that bad though. The term is appropriate in either case, and term
overloading happens all the time ("id" anyone?).
More information about the Standards