[Standards-JIG] Re: Closing idle streams (server comparison chart)

Jean-Louis Seguineau jean-louis.seguineau at laposte.net
Thu Jun 1 13:45:26 UTC 2006


Don't be shy Phillip. Are you ashamed of posting to the list? Or do you keep
your 'goodadvice' to Carlo alone?

Incidentally, in the matter of bombastic declamation, he is a phenomenon. I
would never dream of reaching his master level at ranting ;)
That said, it is not a matter of love/hate, just a matter of correcting the
slight inaccuracies he is so accustomed to.

>From your message I see that

1/ You made a "quick" survey on the "public network". I am just concerned by
the conclusions you have "quickly" drawn from that survey. On the "public
network" jabberd and ejabberd servers represent the vast majority of the
public deployements. That may have entitled you to draw conclusions on these
particular implementations. Not to 'assume' on others. BTW can you point me
to a public Merak server?

2/ From your message, your log only shows the authoritative server part
(steps 5 to 8 of RFC3920 8.3) of a dialback handshake. You said "I tried to
do a version request from hancke.name to im.antepo.com". So you must have
sent a dialback key <db:result to='im.antepo.com'
from='hanke.name'>98AF014EDC0...</db:result> on the first stream, right? 
Now from your SRV record, the authoritative server for the "asserted XMPP
domain" hanke.name is ve.symlynx.com, right? So it is correct that the
receiving server (im.antepo.com) connects back to ve.symlynx.com, right? 
After establishing the streams, the receiving server (im.antepo.com) sends
the authoritative server (ve.symlynx.com) a request for verification of a
key for the seerted domain <db:verify to="hancke.name" from="im.antepo.com"
id="i6hiqapy91">6b13c3.... </db:verify>. Am I missing something? 
At this point, according to RFC3920 8.3.9 the authoritative server
(ve.symlynx.com) is supposed to verify the validity of the key, right? And
that is performed by returning either a <db:verify ... type='valid' or
<db:verify ... type='invalid', am I reading the spec correctly?

Can you then explain why the authoritative server (ve.symlynx.com) generates
a <stream:error> instead?

Everybody would be more comfortable if you could show the entire dialback
sequence, instead of a carefully selected part... To ensure maximum
transparency and accuracy, of course.



-----Original Message-----
From: Philipp Hancke [mailto:fippo at goodadvice.pages.de] 
Sent: Thursday, June 01, 2006 9:13 AM
To: jean-louis.seguineau at laposte.net
Subject: SRV records (was: Re: [Standards-JIG] Re: Closing idle streams
(server comparison chart))

Jean-Louis Seguineau wrote:
> Finally, the XCP server, the OPN server, the Tipic server all requires a
> registration procedure in order to qualify a trial request. The Merak
server
> is available for download but needs an activation key. I strongly doubt
you
> had all these servers installed in your 'lab' for the test. Let me tell
you
> what happened: your server list is just a copy and paste of the list
> available at jabber.org. And you just made those tests results up. 

Could you please stop ranting without having real arguments? 
I think everyone noticed you dont like Carlo.

There are enough servers in the so-called "public network" to do
a quick s2s connection survey...

He assumed that im.antepo.com is running OPN. Is that assumption
wrong? If so, could you please tell me what software you're running
so I can contact the developer with the following problem?

I tried to do a version request from hancke.name to im.antepo.com .
(mh... I probably should have used corp.antepo.com, but the result
  is the same)
Dialback did not achieve any results... it seems to me that your server
does not handle SRV records and is connecting the wrong host.

my DNS setup:
hancke.name is using a _xmpp-server._tcp record which has never
been a problem so far:
_xmpp-server._tcp.hancke.name. 6000 IN  SRV     5 1 5269 
entropie.hancke.name.
whereas
entropie.hancke.name.   5990    IN      CNAME   fippo.dyndns.org.
fippo.dyndns.org.       60      IN      A       217.224.72.42

whereas the server running on
hancke.name.            86400   IN      A       62.75.216.40
port 5269 is ve.symlynx.com


Now ve.symlynx.com logs show the following:
(> is incoming traffic, < outgoing traffic)
logon       "Tue May 16 20:42:09 2006"
> <?xml version="1.0"?>
> <stream:stream xmlns:stream="http://etherx.jabber.org/streams"
        xmlns="jabber:server" xmlns:db="jabber:server:dialback">
< <?xml version='1.0' encoding='UTF-8' ?>
   <stream:stream xmlns='jabber:server' xmlns:db='jabber:server:dialback'
                  xmlns:stream='http://etherx.jabber.org/streams'
                  xml:lang='en' id='22a0b6a6' from='ve.symlynx.com' >


> <db:verify to="hancke.name" from="im.antepo.com" id="i6hiqapy91">
> 6b13c3611a928e5c206203c782e0e8917e3d7e08</db:verify>
< <stream:error><host-unknown
               xmlns='urn:ietf:params:xml:ns:xmpp-streams'/>
               <text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>
               </text></stream:error></stream:stream>
disc        "Tue May 16 20:42:09 2006"

Can you tell me why you're routing this packet to that host?
It seems that the software is either ignoring the SRV record
or the SRV lookup fails for some reason.

Thanks in advance. I am looking forward to generating tcpdump
files for the connection.

Philipp




More information about the Standards mailing list